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Online Help

Online Help for BioConfirm is available as part of MassHunter Help and Learning. 
Online Help provides more information and can be displayed in the following 
ways:
• Click Contents from the Help menu.
• Press the F1 key to get more information about a window or dialog box.

Agilent Community

To get answers to your questions, join over 10,000 users in the Agilent 
Community. Review curated support materials organized by platform 
technology. Ask questions to industry colleagues and collaborators. Get 
notifications on new videos, documents, tools, and webinars relevant to your 
work.

https://community.agilent.com
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How to use this guide
How to use this guide

Try to do these introduction exercises initially using the steps listed in the first 
column. Then if you need more information, follow the detailed instructions in the 
second column.

Before you start

Copy the data files used for these tasks onto your hard disk as follows:
1 Create a project. You select a project before you start BioConfirm. See the 

online Help for OpenLab Control Panel for more information.
2 Copy all of the data files from the Data folder on the BioConfirm setup media 

to your computer hard drive. 
• For Workstation mode, copy the data files to the Data folder in your project.
• For Networked Workstation mode, import the data files into your project. 

See “Import Data Files and Sequences” on page 4.
3 In Workstation mode, make sure you have both read and write permissions 

for the folder you just created on your computer. This is required if you want 
to save results.
a In Windows Explorer right-click the folder where you copied the data files 

and click Properties from the shortcut menu.
b Clear the Read-only Attributes check box if it is marked.
c In the Confirm Attribute Changes dialog, click Apply changes to this folder, 

subfolders, and files, and then click OK.
4 Copy all of the sequences from the ProteinSequences folder on the 

BioConfirm setup media to your computer hard drive. Example protein 
sequences and oligonucleotide sequences are in this folder.
• For Workstation mode, copy the sequences to the ProteinSequences folder 

in your project.
• For Networked Workstation mode, import the sequences into your project. 

See “Import Data Files and Sequences”.
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How to use this guide
Import Data Files and Sequences

In Workstation mode, you can copy the data files and sequences directly to your 
project. In Networked Workstation mode, you import these files to the project. 
You can also import methods, report templates, and databases.
1 Copy all of the data files from the Data folder on the BioConfirm setup media 

to your computer hard drive. 
2 Start the OpenLab Control Panel program.
3 Create a project. See the online Help for the Control Panel program for more 

information.
4 Select the project.
5 In the Control Panel program on the ribbon in the BioConfirm group, click 

BioConfirm > Start BioConfirm. If you are starting BioConfirm with a new 
project for the first time, you may get a message about default files being 
automatically imported. If you get this message, wait a few minutes, and then 
try to open BioConfirm again.

6 Click Cancel in the Open Sample dialog box.
7 Click File > Import to Project > Data File(s). The Data File Import dialog box 

opens.
8 Select the data file(s) to import. These files are used for exercises in this 

guide: 40mer_MSMS_14CS_14CE.d, DAR_Sample_Intact.d, 
DAR_Sample_Reduced.d, NIST mAb 1.d, NIST mAb 2.d, NIST mAb Digest.d, 
NIST mAb Digest2.d, Oligo_40mer_MS1.d, ReleasedGlycans1.d, and 
ReleasedGlycans2.d, 

9 Click Import. It takes several minutes to import data files, so you may have to 
wait before continuing.

10 Click File > Import to Project > Sequence(s). The Sequence Import dialog box 
opens.

11 Select the sequence(s) to import.
12 Click Import.
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Basic Tasks
Task 1. Open the BioConfirm program
Basic Tasks

Task 1. Open the BioConfirm program

In this task you open multiple data files using the current method. 
 

Steps Detailed Instructions Comments

1 Open the BioConfirm program. a Double-click the Control Panel icon on 
the desktop. 

b Click Projects in the left pane.
c Select a project.
d On the ribbon in the BioConfirm group, 

click BioConfirm > Start BioConfirm.

• You can get help for any window, 
dialog box, or tab by pressing the F1 
key when that window is active.

• Learn how to create a project in the 
online Help for Control Panel.

• You can create BioConfirm shortcuts 
on the desktop. These shortcuts are 
specific to the selected project. See 
the online Help for more information.

Figure 1. Start BioConfirm from the Control Panel program
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Basic Tasks
Task 1. Open the BioConfirm program
2 Open these data files:
• NIST mAb 1.d
• NIST mAb 2.d
• NIST mAb Digest.d
• NIST mAb Digest2.d
• ReleasedGlycans1.d
• ReleasedGlycans2.d

• Make sure that the Use current 
method button is clicked.

• Make sure that the Load result 
data check box is cleared.

a In the Open Sample dialog box, go to the 
Data folder in your project.

• Only some example files were copied 
to the hard disk for these examples.

• You can get help for any window, 
dialog box, or tab by pressing the F1 
key when that window is active.

Figure 2. Open data files when opening software

Steps Detailed Instructions Comments
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Basic Tasks
Task 1. Open the BioConfirm program
b Click the NIST mAb 1.d file.
c Press and hold the Shift key while you 

click NIST mAb Digest2.d.
d Press and hold the Ctrl key while you 

click ReleasedGlycans1.d and 
ReleasedGlycans2.d.

e Clear the Load result data check box.
f Click Open.

All the data files are displayed in the 
Sample Table window. The selected 
sample in the Sample Table is also 
shown in the Sample Chromatogram 
Results window.

g Click the List Mode button ( ) in the 
Sample Chromatogram Results toolbar.

h Click the NIST mAb 1.d data file in the 
Sample Table window.

• If you press the Shift key, you can pick 
a group of files that are directly next to 
each other.

• If you press the Ctrl key, you can pick 
files which are not directly next to 
each other in the list.

• What you see in the main window at 
this point depends on the method, 
layout, display and plot settings used 
before you opened these files.

• When you click the List Mode button, 
the background of the button 
changes to orange.( )

3 Return the main window to the 
default Intact Protein layout.

• Click Intact Protein Layout in the main 
toolbar.

• If you want to change the display 
options, you click the  button in 
the graphics window.

• You can switch between layouts for 
the different workflows when you 
click the buttons in the main toolbar.

• You can change the layout if you click 
Configuration > Window Layouts > 
Load Layout.

• Columns in a table can be hidden. 
Some default columns in the Sample 
Table are hidden.

Steps Detailed Instructions Comments
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Basic Tasks
Task 1. Open the BioConfirm program
Figure 3. BioConfirm main window

Steps Detailed Instructions Comments
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Basic Tasks
Task 2. Zoom in and out of the chromatogram
Task 2. Zoom in and out of the chromatogram

In this task, you become familiar with the zoom in and zoom out features of the 
BioConfirm program.

Steps Detailed Instructions Comments

1 Practice zooming in and out on the 
chromatogram in the Sample 
Chromatogram Results window.
• Zoom in twice on the peak.
• Zoom in one more time 

autoscaling the y-axis.
• Zoom out once to the previous 

zoom position.
• Completely zoom out to the 

original chromatogram.

a Click the right mouse button and drag 
over an area on the last peak. 
Make sure that the Autoscale Y-axis 
during Zoom button, , is not 
selected for this step. 

b Repeat step a.
c Click the Autoscale Y-axis during Zoom 

button, , in the toolbar. 
d Click the right mouse button again and 

drag over an area of the peak for the third 
time.
The BioConfirm program 
automatically scales the y-axis to the 
largest point in the range.

e Click the Unzoom button, , to undo 
the last zoom operation. 
You can undo the last fifteen zoom 
operations.

f Click the Autoscale X-axis and Y-axis 
button, , to zoom out completely. 

• You can also use these zoom 
features in the Biomolecule MS 
Spectrum window, the Biomolecule 
Fragment Spectrum window, the 
Deconvolution Results window, the 
Deconvolution Mirror Plot window, 
and the Biomolecule MS 
Chromatogram window.

• In addition to those windows, you can 
also zoom on the x-axis and y-axis 
and use the toolbar buttons in the 
Relative Quantitation Histograms 
window. You cannot drag over an 
area in the Relative Quantitation 
Histograms window.

• A selected button has an orange 
background color.
Agilent MassHunter BioConfirm Software Introduction Guide 9



Basic Tasks
Task 2. Zoom in and out of the chromatogram
2 Practice zooming in and out on each 
axis separately.
• Zoom in only along the x-axis.
Hint: Right-click the x-axis values 
and move cursor from left to 
right.
• Partially zoom out the x-axis.
Hint: Move cursor in the opposite 
direction.
• Completely zoom out of the x-axis.
• Repeat the previous steps for the 

y-axis.

a To zoom in on the x-axis, move the 
cursor to the x-axis values until a 
horizontal double arrow appears.

b Click the right mouse button and drag 
the new cursor from left to right across 
the x-axis values. 

c To zoom out on the x-axis, click the right 
mouse button and drag from right to left 
on the x-axis values.

d Click the Autoscale X-axis button, , to 
completely zoom out on the x-axis. 

a To zoom in on the y-axis, move the 
cursor to the y-axis values until a vertical 
double arrow appears.

b Click the right mouse button and drag 
the new cursor from bottom to top 
across the y-axis values. 

c To zoom out on the y-axis, click the right 
mouse button and drag from the top 
towards the bottom of the y-axis values.

d Click the Autoscale Y-axis button, , to 
completely zoom out on the y-axis.

Steps Detailed Instructions Comments

Horizontal Double 
Arrow

New cursor appears 
when you right-click 
the x-axis value

Vertical Double Arrow

New cursor appears when 
you right-click the y-axis 
values.
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Basic Tasks
Task 3. Change window layouts
Task 3. Change window layouts

In this task, you move windows within the main view and create various window 
layouts. Default layouts are available for the Intact Protein workflow, the Protein 
Digest workflow, the Released Glycans workflow, the Oligonucleotides - Target 
Plus Impurities workflow, and the Oligonucleotides - Sequence Confirmation 
workflow.
Agilent MassHunter BioConfirm Software Introduction Guide 11



Basic Tasks
Task 3. Change window layouts
Steps Detailed Instructions Comments

1 Change the window layout:
• Change the window size.
• Save a window layout.
• Unlock the layout.
• Change the Chromatogram 

Results window to be floating.
• Move the Chromatogram Results 

window.
• Display the tools for repositioning 

the windows.

• To change the size of a window, drag the 
boundary between the windows.

• To load the default layout for a workflow, 
click one of the buttons in the main 
toolbar: 
• Intact Protein Layout
• Protein Digest Layout
• Released Glycans Layout
• Oligos - Target Plus Impurities Layout
• Oligos - Sequence Confirmation 

Layout
• To load a layout, click Configuration > 

Windows Layouts > Load Layout.
• To save a window layout, click 

Configuration > Window Layouts > Save 
Layout.

• To lock or unlock a layout, click 
Configuration > Window Layouts > Lock 
Layout. 

• To make a window float, right-click the 
title bar of the window, and click Floating 
from the shortcut menu.

• To move a window, click the title bar of 
the window and drag the window to the 
desired location. 

• To display the repositioning tools, drag 
the window over one of the other 
windows. When one window is 
overlapped with another, the program 
displays several layout tools, as shown in 
Figure 4.

• If the layout is locked, the system 
displays a check mark next to the 
Lock Layout menu.

• You can only use the repositioning 
tools when the layout is unlocked.

• You can also make a window float by 
double-clicking the title bar of the 
window.

• If two or more windows are tabbed 
together, you can make one window 
float by double-clicking the tab for that 
window.

• The following layouts are shipped 
with the software: 
Default_Intact_Protein.xml 
Default_Protein_Digest.xml
Default_Released_Glycans.xml
Default_Oligonucleotides_TPI.xml
Default_Oligonucleotides_SC.xml
Default.xml

Figure 4. Window repositioning tools
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Basic Tasks
Task 3. Change window layouts
2 Reposition the Sample 
Chromatogram Results window.
• Move the window so that it is at 

the top, to the left, to the right and 
then at the bottom of the other 
windows.

• Move two windows together so 
that they are on top of one another 
and available only through the tabs 
at the bottom. 

• Restore the default layout.

• If you drag the cursor over one of the 
smaller icons, the window you are 
dragging will be placed above, to the right, 
below, or to the left of all of the other 
windows. 

• Drag the cursor over the larger icon. The 
window can also be placed above, to the 
right, below, or to the left of the other 
window by dragging the cursor over the 
edges of the larger icon.

• To tab two windows together, drag the 
cursor over the center of the larger icon. 
You will see a shadow version of the two 
windows tabbed together. Stop dragging 
the mouse. The two windows will be 
tabbed together.

• Click Intact Protein Layout in the main 
toolbar.

• The cursor must be over one of the 
arrows in a box in order for 
repositioning to occur.

• Click the Configuration > Load 
Default Layout command to load the 
default layout, default.xml.

Steps Detailed Instructions Comments
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Basic Tasks
Task 4. Creating a Protein Sequence File
Task 4. Creating a Protein Sequence File

This task guides you through the creation of a myoglobin protein sequence file. 
You can also create oligonucleotide sequence files. See “Task 6. Creating an 
Oligonucleotide Sequence File” on page 18

Steps Detailed Instructions Comments

1 Start the Agilent MassHunter 
Sequence Manager.

• Click Sequence > Sequence Manager. • You can also start the Sequence 
Manager program from the OpenLab 
Control Panel.

2 Add a sequence. a Click the Proteins tab.
b Click Sequence > Add Sequences > Add 

Protein Sequence.
c Select one or more sequences in the list 

in the Add Protein Sequence(s) dialog 
box.

d Click Open.
The Sequence Editor pane opens 
automatically with that sequence.

• Protein is automatically selected for 
the sequence type.

3 Create a new sequence. a Type Myoglobin for the name of the 
Sequence.

b Click the + button.
The Sequence Editor pane opens 
automatically with a new sequence 
displayed for editing.

• Protein is automatically selected for 
the sequence type.

4 Enter the amino acid sequence 
shown below into the Sequence 
Manager.

• Type in individual amino acids one at a 
time between the N-term and C-term 
symbols. 

• Use the single-character (letter) amino 
acids abbreviations.

GLSDGEWQQVLNVWGKVEADIAGHGQEVLIRLFTGHPETLEKFDKFKHLKTEAEM
KASEDLKKHGTVVLTALGGILKKKGHHEAELKPLAQSHATKHKIPIKYLEFISDAIIHV
LHSKHPGDFGADAQGAMTKALELFRNDIAAKYKELGFQG

• Tip: If you are reading this document 
as a PDF file on your computer, you 
can copy and paste the sequence into 
the Sequence Manager window.

Note: The myoglobin sequence does not have any links or modifications, but some sequences do. In that case, add links and 
modifications as described in the Quick Start Guide or online Help.
14 Agilent MassHunter BioConfirm Software Introduction Guide



Basic Tasks
Task 4. Creating a Protein Sequence File
5 Save the sequence as the name 
iii_myoglob.psq, where iii represents 
your initials.

a Click Sequence > Export Sequence. 
b Type iii_myoglob in the File name box.
c Click Save. 

• The sequence is saved as a .psq file 
that can be transferred to other 
computers or projects.

Figure 5. Creating a sequence file of myoglobin in the Sequence Manager program

6 Save changes in the Sequence 
Manager.

a Click Sequence > Save All Changes.
b In the Save Sequences dialog box, mark 

the check box in front of Myoglobin.
c Enter a description of the change that 

was made.
d Click Save.

• A description is always required when 
you save a sequence.

Steps Detailed Instructions Comments
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Basic Tasks
Task 5. Adding a building block to the Chemical Data Dictionary
Task 5. Adding a building block to the Chemical Data 
Dictionary

This task guides you through the creation of a new building block. Building blocks 
are used when creating an oligonucleotide sequence.

Steps Detailed Instructions Comments

1 Start the Agilent MassHunter 
Chemical Data Dictionary.

• Click Sequence > Open Chemical Data 
Dictionary Editor. 

• You can also start the Sequence 
Manager program and click Open 
definition manager on the 
Oligonucleotides tab.

2 Create a new building block. a Click the Oligonucleotides tab.
b Type kH for the Code.
c Click the + button.

• See the online Help for rules about 
naming new Building blocks.

3 Enter the Name, Molecular formula, 
and Base formula.

a Type the Name for this Building block. 
This name is a description of the Building 
block.

b Type C9H13N3O4 for the Molecular 
formula.

c Type C4H5N3O for the Base formula.

• This example is a duplicate of the 
Building block Deoxycytidine.
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Basic Tasks
Task 5. Adding a building block to the Chemical Data Dictionary
4 Close the program. a Click Close. 
b In the Save Chemical Data Dictionary 

dialog box, enter a reason that the 
change was made.

c Click Yes.

• If you click No in the Save Chemical 
Data Dictionary dialog box, the 
changes are not saved.

Figure 6. Creating a Building block in the Chemical Data Dictionary Editor dialog box

Steps Detailed Instructions Comments
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Basic Tasks
Task 6. Creating an Oligonucleotide Sequence File
Task 6. Creating an Oligonucleotide Sequence File

This task guides you through the creation of an oligonucleotide sequence file. 
You can also create a protein sequence. See “Task 4. Creating a Protein 
Sequence File” on page 14

Steps Detailed Instructions Comments

1 Start the Agilent MassHunter 
Sequence Manager.

• Click Sequence > Sequence Manager. • You can also start the Sequence 
Manager program from the OpenLab 
Control Panel.

2 Add a sequence. a Click the Oligonucleotides tab.
b Click Sequence > Add Sequences > Add 

Oligonucleotide Sequence.
c Select Oligo_40mer_MS.psq and 

Oligo_40mer_MSMS.psq sequences in 
the list in the Add Sequence(s) dialog 
box.

d Click Open.
The Sequence Editor pane opens 
automatically with that sequence.

• The Oligo_40mer_MS sequence and 
the Oligo_40mer_MSMS sequence 
are used in the exercises in this guide.

3 Create a new sequence. a Type Example for the name of the 
Sequence.

b Click the + button.
The Sequence Editor pane opens 
automatically with a new sequence 
displayed for editing.

• Oligonucleotide is automatically 
selected for the sequence type.

4 Enter the building block sequence 
shown below into the Sequence 
Manager.

a Type in Building blocks one at a time 
between the 5’ and 3’ symbols. 

b Mark the If two building blocks are next 
to each other, insert linker check box.

c Select p for the linker.

• Use the Code for the Building block.
• The Total monoisotopic mass is 

6498.1153 after adding these building 
blocks. 

TGACTGTGAACGTTCGGATGA • Tip: If you are reading this document 
as a PDF file on your computer, you 
can copy and paste the sequence into 
the Sequence Manager window.
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Basic Tasks
Task 6. Creating an Oligonucleotide Sequence File
5 Save the sequence as the name 
iii_Example.psq, where iii represents 
your initials.

a Click Sequence > Export Sequence. 
b Type iii_Example in the File name box.
c Click Save. 

• The sequence is saved as a .psq file 
that can be transferred to other 
computers or projects. 

Figure 7. Creating an oligonucleotide sequence in the Sequence Manager program

6 Save changes in the Sequence 
Manager.

a Click Sequence > Save All Changes.
b In the Save Sequences dialog box, mark 

the check box in front of Example.
c Enter a description of the change that 

was made.
d Click Save.

• A description is always required when 
you save a sequence.

Steps Detailed Instructions Comments
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Intact Protein Workflow
Task 6. Creating an Oligonucleotide Sequence File
Intact Protein Workflow

t

Step 1 - Open the data file of interest and select the Intact Protein layout.
Step 2 - Open a BioConfirm method or create a new one.
Step 3 - Edit protein sequences if necessary in the Sequence Manager program:
• Add or edit the sequence text
• Apply or edit modifications
• Apply or edit links
Step 4 -Select Intact Protein for the Workflow on the Workflow and Sequences 
tab. Select the Condition.
Step 5 - Select the Sequence/Masses to match on the Workflow and Sequences 
tab.
If the sequence you want to match is not in the method or Select Sequences 
dialog, then:
Import or create a sequence.
Step 6 - Select the Mods and Profiles on the Workflow and Sequences tab.
Step 7 - Run the Method Workflow.
Step 8 - Review the results which are shown in these windows:
Sample table
Biomolecules table
Biomolecule Identification Results
Deconvolution Results
Biomolecule MS Chromatogram
Biomolecule MS Spectrum
Results Compare
Relative Quantitation Histograms
Step 9 - Print report.
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Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow

This exercise shows you how to set method parameters, match an intact protein 
sequence, and view the results. This exercise uses the NISTmAb.seq sequence 
file and the NIST mAb 1.d data file copied before you started. See “Before you 
start” on page 3.

If you select the Intact Protein workflow, the Find by Protein Deconvolution 
algorithm runs and uses protein Matching Rules (Intact Protein, and Variable 
Modifications). You can select whether or not Protein Truncation is done.

Steps Detailed Instructions Comments

1 Open the method to use as a starting 
point.

a Click Method > Open.
b Select BioConfirmIntactProtein-Default.m.
c Click Open.

• You may be asked whether or 
not save Method changes 
before loading a new method.

2 If the NIST mAb 1.d data file is not 
already open, open it. 

a Click File > Open Data File.
b Select NIST mAb 1.d.
c Click Open.

• The TIC is automatically 
displayed in the Sample 
Chromatogram Results 
window.

3 Select the Intact Protein layout. • Click Intact Protein Layout in the main 
toolbar.

• You can instead click 
Configuration > Window 
Layouts > Load Layout.
Then, select 
Default_Intact_Protein.xml, and 
click Open.

4 Display the Deconvolute (Protein) 
section in the Method Editor window.

a Click View > Method Editor if the Method 
Editor is not visible.

b Select Intact Protein > Deconvolute 
(Protein) in the Method Editor window.

5 Run the Find by Protein Deconvolution 
algorithm.

a Review the settings and modify them if 
necessary.

b Click  on the Method Editor toolbar to 
start the Find by Protein Deconvolution 
algorithm. 

c If the Find Proteins dialog box opens, select 
NIST mAb 1.d and click Find.

d Review the results in the Biomolecules 
window.

• In this case you are using the 
default method parameters. For 
some data files, you will need to 
use different parameters as 
described in the Quick Start 
Guide or online Help.

• If you have more than one data 
file open, the Find Proteins 
dialog box opens.

6 Display the Workflow and Sequences 
section in the Method Editor window.

• Click Method Automation > Workflow and 
Sequences in the Method Editor window. 
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Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
7 Import the NISTmAb sequence. a Select Intact Protein for the Workflow.
b Select non-reduced for the Condition.
c Click the  button next to the 

Sequences/Masses parameter. The Select 
Sequences dialog box opens.

d Double-click NISTmAb. If NISTmAb is not 
available, click Add.

e Select NISTmAb.psq and click Open.
f Verify that the NISTmAb sequence is in the 

Selected list. 
g Click OK.

• You will use the sequence as is. 
You can add or modify 
modifications and links to 
sequences as described in 
online Help and the Quick Start 
Guide.

8 Select the mAb modification. a Click the  button next to the Mods 
and Profiles parameter. The Select 
Modifications and Profiles dialog box 
opens.

b Double-click mAb in the Available list in the 
Modifications and profiles section.

c Click OK.

• The mAb sequence has 
modifications. You can learn 
how to add modifications in the 
online Help and the Quick Start 
Guide.

• Review the modifications in the 
Modification Summary.

9 Start the match search. a Click Intact Protein > Match Tolerances.
b Click on the Method Editor toolbar.

c If necessary, select NIST mAb 1.d and click 
Match.

• You can instead click Find and 
Identify > Match Sequences > 
Match Sequences (Proteins).

• If you have multiple data files 
open, then you select which 
data files to update.

10 Review the results. • Select the Biomolecule 1 row in the 
Biomolecules table.

• In the 
BioConfirmIntactProtein-default 
layout, the Biomolecule 
Identification Results window is 
tabbed with the Biomolecules 
window.

Steps Detailed Instructions Comments
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Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
Steps Detailed Instructions Comments
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Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
11 Save the method for use in Exercise 2. a Click Method > Save As.
b Type the File name iii_NIST_mAb_Intact.m, 

where iii represents your initials. 
c Click Save.
d If needed, enter a reason in the Reason for 

Change dialog box.
e Click OK.

• You may see additional 
changes listed in the dialog box 
if you made other changes.

12 Investigate the Relative Quantitation 
feature. You normally use this feature to 
quantitate proteoforms (PTMs on the 
protein). 

a In the Biomolecules window, hide all empty 
columns. Click  in the Biomolecules 
toolbar.

b Review the values for Use for %Quant 
column for the biomolecules. 

c Review the values for the %Quant (Decon 
Height) and %Quant (Decon Area).

• You can right-click the window 
and click Add/Remove columns 
to change the columns that are 
available.

Steps Detailed Instructions Comments
24 Agilent MassHunter BioConfirm Software Introduction Guide



Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
d Review the results in the Relative 
Quantitation Histograms window. For an 
Intact Protein workflow, this window only 
contains data if the Use for %Quant check 
box is marked in the Biomolecules window 
for one or more biomolecules and if the 
sequence has predicted modifications.

Steps Detailed Instructions Comments
Agilent MassHunter BioConfirm Software Introduction Guide 25



Intact Protein Workflow
Exercise 1. Interactive Intact Protein Workflow
13 Save the results. a Click File > Save Results.
b Select NIST mAb 1.d in the Save Data File 

dialog box. Click Save.
c If needed, enter a reason on the Reason for 

Change dialog box. Click OK.

• You can save results with the 
data file. You can select whether 
to open these results when you 
open the data file.

• The administrator can set up 
the project so that you need to 
enter a reason when you save 
results to a data file. You may be 
able to enter your own reason or 
you may need to select a reason 
from a list.

• If you want to save the results, 
you need to save them before 
you change the method. If you 
do not, then you will need to 
generate the results again.

Steps Detailed Instructions Comments
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Exercise 2. Automated Intact Protein Workflow
Exercise 2. Automated Intact Protein Workflow

This exercise guides you through the setup of a worklist to automatically confirm 
the presence of NISTmAb in a previously acquired sample. This exercise uses the 
NIST mAb 1.d data file copied in Exercise 1.

Steps Detailed Instructions Comments

1 If not already open, open the method 
iii_NIST_mAb_Intact.m.

a Click Method > Open.
b Select the iii_NIST_mAb_Intact.m folder.
c Click Open.

This method was created in “Exercise 
1. Interactive Intact Protein 
Workflow” on page 21.

2 Open the automation section in the 
Method Editor window.

• Click Method Automation > Workflow and 
Sequences in the Method Editor window. 

3 Use the Intact Protein Workflow. • Confirm that Intact Protein is selected for 
the Workflow.

• In this case you are using the 
default method parameters. For 
some data files, you will need to 
use different parameters as 
described in the Quick Start Guide 
or online Help.

4 Select the NISTmAb sequence. a Select non-reduced for the Condition.
b Click the  button next to the 

Sequences parameter. The Select 
Sequences dialog box opens.

c If NISTmAb is not available, click Add.
d Select NISTmAb.psq and click Open.
e Verify that the NISTmAb sequence is in the 

Selected list. 
f Click OK.

• The NISTmAb.psq sequence file is 
available on the BioConfirm setup 
media.

• You can learn about modifications 
and links in the online Help and in 
the Quick Start Guide.

5 Select mAb as the modification and 
profile.

a If needed, click the  button next to the 
Mods and Profiles parameter. The Select 
Modifications and Profiles dialog box 
opens.

b Double-click mAb in the Available list.
c Click OK.
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6 Save the method. • Click Method > Save.
• If needed, enter the reason for the change.

• If you mark the Calculate 
Drug-to-Antibody Ratio check box, 
the software will calculate DAR for 
the data file. See “Exercise 15. 
Calculate DAR” on page 78 for 
more information.

7 Run the method workflow or run 
method automation.

• Click Method > Run Method Workflow.
• Click Method > Run Method Automation 

(Workflow + Reports).
• Click on the Method Editor toolbar.
• Reprocess the sample. See “Exercise 11. 

Reprocess Samples” on page 62.

• Method Automation first runs the 
method workflow, and then 
extracts additional 
chromatograms and generates a 
biomolecule report and exports 
results.

8 Save the results. a Click File > Save Results.
b Select NIST mAb 1.d in the Save Data File 

dialog box. Click Save.
c If needed, enter a reason on the Reason for 

Change dialog box. Click OK.

• You save results before modifying 
the method again.

Steps Detailed Instructions Comments
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Exercise 2. Automated Intact Protein Workflow
9 (optional) Review the printed 
Biomolecule reports.

• If you clicked Run Method Automation, then 
a report is generated automatically.

• Before you can interactively print a report, 
you need to save the results. You click File > 
Save Results to save the results.

• You can click File > Print > Biomolecule 
Report to generate a report for the current 
sample.

• You set report options in the 
Method Editor window in the 
Method Automation > Reports 
section.

• If you are creating a report 
interactively, you specify some of 
these parameters in the Print 
Biomolecule Report dialog box.

Steps Detailed Instructions Comments
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Exercise 2. Automated Intact Protein Workflow
Protein Digest Workflow

The steps outlined below show the workflow for Protein Digest with MassHunter 
BioConfirm.

Step 1 - Open the data file of interest and select the Protein Digest workflow.
Step 2 - Open a BioConfirm method or create a new one.
Step 3 - Edit sequences if necessary in the Sequence Manager program:
• Add or edit the sequence text.
• Apply or edit modifications
• Apply or edit links
Step 4 - Select the Workflow on the Workflow and Sequences tab. Select the 
Condition.
Step 5 - Select the Sequences/Masses to match on the Workflow and 
Sequences tab.
If the sequence you want to match is not in the method or Select Sequences 
dialog box, then:
Import or create a sequence.
Step 6 - Select the Mods and Profiles on the Workflow and Sequences tab.
Step 7 - Mark the Enzymes on the Workflow and Sequences tab.
Step 8 - Run the Method Workflow.
Step 9 - Review the results which are shown in these windows:
Biomolecules table
Biomolecule Identification Results
Sequence Coverage Map
Biomolecule MS Spectrum
Biomolecule Fragment Spectrum
Peptide Relative Quantitation Results
Results Compare
Relative Quantitation Histograms
Step 10 - Print report.
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Exercise 3. Interactive Protein Digest Sequence Matching
Exercise 3. Interactive Protein Digest Sequence 
Matching

This exercise shows you how to confirm protein digests interactively.

If you select the Protein Digest workflow, the Find Peptides algorithm runs and 
uses the enzyme selected in the Workflow and Peptides section and then runs 
the Protein Digest matching rules. See “Before you start” on page 3.

Steps Detailed Instructions Comments

1 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select the 

BioConfirmProteinDigest-Default.m folder.
c Click Open.

• The parameters in the 
BioConfirmProteinDigest-Default.
m method are a good starting 
point for Protein Digests.

2 Load the Protein Digest default 
layout.

• Click Protein Digest Layout on the main 
toolbar.

3  Select NIST mAb Digest.d. If the 
data file NIST mAb Digest.d is not 
open, open the data file.

• If available, select NIST mAb Digest.d.
Otherwise, do the following:
a Click File > Open Data File.
b Locate the NIST mAb Digest.d sample.
c Clear the Load result data check box.
d Click Open.

• The TIC is automatically 
displayed in the Sample 
Chromatogram Results window.

4 Review the parameters in the Find 
Peptides section in the Method 
Editor window.

a Select Protein Digest > Find Peptides in the 
Method Editor window.

b Review the settings on the various tabs of the 
Find Peptides section.

c Click the Charge State tab.
d Review the parameters.

• You can change the default 
parameters as described in the 
next steps. You can also use the 
method without any changes.

• For some data files, you will need 
to use different parameters as 
described in the online Help.

• A very low peak height filter can 
result in greater sequence 
coverage but requires much 
more time to process.

5 Run the Find Peptides algorithm. a Click  on the Method Editor toolbar to start 
the biomolecule search. 

b If the Find Peptides dialog box opens, select 
NIST mAb Digest.d and click Find.

c When processing is complete, review the 
results in the Biomolecules window.

• You can instead click Find and 
Identify > Find Peptides.
Agilent MassHunter BioConfirm Software Introduction Guide 31



Protein Digest Workflow
Exercise 3. Interactive Protein Digest Sequence Matching
6 Add the sequence. a Click Method Automation > Workflow and 
Sequences in the Method Editor window.

b Select Protein Digest as the Workflow.
c Select reduced as the Condition.
d Click the  next to the 

Sequences/Masses parameter.
e Double-click NISTmAb.
f Click OK in the Select Sequences dialog box.
g Click the  next to the Mods and Profiles 

parameter.
h Double-click Protein Digest 

(Reduced+Alkylated).
i Click OK in the Select Modifications and 

Profiles dialog box.
j Mark the Trypsin check box under Enzymes.

• For this exercise, you use the 
sequence as is, but you can add 
modifications and links to 
sequences as described in online 
Help.

• You can customize the list of 
available reagents using the 
Chemical Data Dictionary; see 
online Help for more information.

7 Review parameters on the Mass 
Matching tab. 

a Click the Mass Matching tab in the Protein 
Digest > Match Tolerances section of the 
Method Editor window.

b Review the parameters.

8 Review the Matching Rules. a Click the Matching Rules tab in the Protein 
Digest > Match Tolerances section in the 
Method Editor.

b Mark the Allow free cysteines (non-reduced 
condition) check box.

c Enter 2 for the Allow missed cleavages up to.
d Review the other parameters.

9 Save the method for use in Exercise 
7.

a Click Method > Save As.
b Type the File name 

iii_NIST_mAb_ProteinDigest.m, where iii 
represents your initials. 

c Click Save. 
d If needed, enter a reason on the Reason for 

Change dialog box and click OK.

• The administrator can set up the 
project to require you to enter a 
reason when you save a method. 
You may be able to enter your 
own reason, or you may need to 
select a reason from a list of 
possible reasons.

Steps Detailed Instructions Comments
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10 Start the match search. a Click Find and Identify > Match Sequences > 
Match Sequences (Proteins).

b Select NIST mAb Digest.d.
c Click Match.

Alternate methods:
• Click  on the Method Editor 

toolbar.
• Click Match Sequences on the 

Method Editor shortcut menu. 

11 Review the results. a Highlight Biomolecule 3 in the Biomolecules 
window.

b Click the Biomolecule Identification Results 
tab which is tabbed with the Biomolecules 
window. 

c When you open the window, the window 
displays the results for the first biomolecule 
that is selected in the Biomolecules window. 

d Select another sequence match result to view 
by selecting a different biomolecule in the 
Biomolecules window. 

• If the biomolecule was identified, 
the ID Techniques Applied 
column contains Target Mass 
Match.

12 View sequence coverage results. a If necessary, click View > Sequence 
Coverage Map.

b Select a different biomolecule in the 
Biomolecules table to view a different result.

• Amino acids that are matched 
are either green (MS/MS) or black 
(MS-only) in a matched 
sequence. 

• Amino acids that are not 
matched are gray.

• A line is added below the AA 
sequence to display where 
peptides have been identified.

• See the online Help for more 
information.

To view more information. Click the following items on the Sequence 
Coverage Map window shortcut menu to view 
more information about the sequence: 
• Applied Modifications 
• Specified Applied Links 
• View Digest List

Steps Detailed Instructions Comments
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Exercise 3. Interactive Protein Digest Sequence Matching
13 Save the method and results a Click Method > Save.
b If needed, enter a reason on the Reason for 

Change dialog box, and click OK.
c Click File > Save Results to save your results 

to the data file folder.
d If needed, enter a reason on the Reason for 

Change dialog box and click OK.

• You can also click  to save 
results.

14 Review the results in the Peptide 
Relative Quantitation Results 
window.

a Click View > Peptide Relative Quantitation 
Results. It is not visible in the default layout. 
When it is visible, it is tabbed with the 
Biomolecules window.

b Click the first triangle next to the first row.
c Note that Use for %Quant is marked for each 

row.

• For Protein Digest workflow, the 
software uses the Use for 
%Quant check box in the Peptide 
Relative Quantitation Results 
window.

Steps Detailed Instructions Comments
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Protein Digest Workflow
Exercise 3. Interactive Protein Digest Sequence Matching
15 Review the results in the Relative 
Quantitation Histograms window.

a Click the Relative Quantitation Histograms 
window.

b Click the first triangle next to the first row.
c Note that Use for %Quant is marked for both 

rows.

• For Protein Digest workflow, the 
software uses the Use for 
%Quant check box in the Peptide 
Relative Quantitation Results 
window.

16 Repeat the interactive processing 
with NIST mAb Digest2.d.

a If needed, open the data file NIST mAb 
Digest2.d (see step 3).

b Select Find Peptides in the Method Editor and 
verify the parameters(step 4).

c Find biomolecules (step 5).
d Match sequences (step 10).
e Save the results to the NIST mAb Digest2.d 

file (step 13).

• Most of the processing 
parameters used for the first data 
file are the same for the second 
data file.

• These results are used in 
“Exercise 12. Use Result Review 
mode” on page 65.

Steps Detailed Instructions Comments
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Exercise 4. Automated Protein Digest Workflow
Exercise 4. Automated Protein Digest Workflow

This exercise guides you through the setup of a worklist to automatically confirm 
the presence of NIST mAb in a previously acquired sample.

If you select the Protein Digest workflow, the Find Peptides algorithm runs and 
uses the enzymes selected in the Workflow and Peptides section and then runs 
the Protein Digest matching rules.

Steps Detailed Instructions Comments

1 Open the method. a Click Method > Open.
b Select the iii_NIST_mAb_ProteinDigest.m 

folder.
c Click Open.

• This method was created in 
Exercise 3 (iii represents your 
initials).

2 Display the Method Automation > 
Workflow and Sequences section in 
the Method Editor.

a If the Method Editor is not visible, click View 
> Method Editor. 

b Click Method Automation > Workflow and 
Sequences in the Method Editor window. 

• You can instead click the Method 
Editor button, , on the main 
toolbar.

3 Select the appropriate workflow. a Select Protein Digest for the Workflow.
b Select reduced for the Condition.
c Verify that NISTmAb is the sequence.
d Verify that Protein Digest 

(Reduced+Alkylated) is the Mods and 
Profiles.

e Mark the Trypsin check box.

• The Protein Digest workflow 
automatically runs the following 
actions:
• Find Peptides
• Match Sequences

4 Save the method. a Click Method > Save.
b If needed, enter a reason for the change.

5 Run the method workflow or run 
method automation.

• Click Method > Run Method Workflow.
• Click Method > Run Method Automation 

(Workflow + Reports).
• Click on the Method Editor toolbar.
• Reprocess the sample. See “Exercise 11. 

Reprocess Samples” on page 62.

• Method Automation first runs the 
method workflow and then 
extracts additional 
chromatograms, generates a 
biomolecule report, and exports 
results.

6 (optional) Review the printed 
Biomolecule reports.

• If you clicked Run Method Automation 
(Workflow + Reports), then a report is 
generated automatically.

• You can click File > Print > Biomolecule 
Report to generate a report for the current 
sample.

• You set report options in the 
Method Editor window in the 
Method Automation > Reports 
section.

• If you are creating a report 
interactively, you specify some of 
these parameters in the Print 
Biomolecule Report dialog box.
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Exercise 4. Automated Protein Digest Workflow
Released Glycans Workflow

The steps outlined below show the workflow for Released Glycans with 
MassHunter BioConfirm.

Step 1 - Open the data file of interest and select the Released Glycans layout.
Step 2 - Open a BioConfirm method or create a new one.
Step 3 - Select the Workflow on the Workflow and Sequences tab.
Step 4 - Select the Target glycan source.
Step 5 - Select the tag which you used. 2-AB and InstantPC are listed, and you 
can create your own.
Step 6 - Run the Method Workflow.
Step 7 - Review the results which are shown in these windows:
Sample Chromatogram Results
Biomolecule MS Chromatogram
Biomolecules table
Biomolecule Identification Results
Biomolecule MS Spectrum
Glycan Structure Viewer
Results Compare
Relative Quantitation Histograms
Step 8 - Print report.
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Exercise 5. Interactive Released Glycans

This exercise shows you how to find released glycans interactively.

If you select the Released Glycans workflow, the Find Glycans algorithm runs. 
See “Before you start” on page 3.

Steps Detailed Instructions Comments

1 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select the 

BioConfirmReleasedGlycans-Default.m 
folder.

c Click Open.

• The parameters in the 
BioConfirmReleasedGlycans-Def
ault.m method are a good 
starting point for Released 
Glycans.

2 Open the example sample file. a If needed, click File > Open Data File.
b Select ReleasedGlycans1.d.
c Click Open.

• The TIC is automatically 
displayed in the Sample 
Chromatogram Results window.

3 Load the Released Glycans layout. • Click Released Glycans Layout in the main 
toolbar.

4 Review the parameters in the Find 
Glycans section in the Method Editor 
window.

a Select Method Automation > Workflow and 
Sequences in the Method Editor window.

b Select Released Glycans.
c Enter Example in the Glycan group.
d Clear Require RT match if database contains 

a RT for the target glycan.
e Select Released Glycans > Find Glycans in 

the Method Editor window.
f Select Glycans_mAb_AM_PCD.cdb for 

the Target glycan source.
g Click the Tag tab.
h Click the option for the correct tag. For the 

example data file, click InstantPC.

• You can change the default 
parameters as described in the 
next steps.

• For some data files, you will need 
to use different parameters as 
described in the online Help.

• Some structures are included in 
the Glycans_mAb_AM_PCD.cdb 
file.

• A very low peak height filter can 
result in greater sequence 
coverage but requires much 
more time to process.

5 Run the Find Glycans algorithm. a Click  on the Method Editor toolbar to start 
the biomolecule search. 

b When processing is complete, review the 
results in the Biomolecules window.

c Click View > Glycan Structure Viewer.

6 Save the method for use in Exercise 
6.

a Click Method > Save As.
b Type the File name 

iii_ReleasedGlycans_InstantPC.m, where iii 
represents your initials. 

c Click Save. 
d If needed, enter a reason on the Reason for 

Change dialog box. Click OK.
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7 Review the results. a In the Biomolecules window, click the header 
of the Area (FBF) column to sort the table by 
this column. If necessary, click the header 
again so that the largest areas are at the top 
of the table. 

b Highlight G0F in the Biomolecules window.
c Click the Biomolecule Identification Results 

tab. The Biomolecules Identification Results 
window is tabbed with the Biomolecules 
window. 

d When you open the window, the window 
displays the results for the first biomolecule 
that is selected in the Biomolecules window. 

• Several changes were made to 
the default layout for the image 
below. The Glycan Structure 
Viewer window is visible. Also, the 
Flags (Tgt) column was moved.

• The Relative Quantitation 
Histograms window only 
contains information when you 
run a workflow.

8 Save the results a Click File > Save Results to save your results 
to the data file folder.

b If needed, enter a reason for the change.

• You can also click  to save 
results.

Steps Detailed Instructions Comments
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Exercise 6. Automated Released Glycans Workflow

This exercise guides you through the setup of a worklist to automatically run the 
Released Glycans workflow.

If you select the Released Glycans workflow, the Find Glycans algorithm runs and 
uses the Target glycan source selected in the Workflow and Sequences section.

Steps Detailed Instructions Comments

1 Open the method. a Click Method > Open.
b Select the 

iii_ReleasedGlycans_InstantPC.m folder.
c Click Open.

• This method was created in 
Exercise 5 (iii represents your 
initials).

2 Display the Method Automation > 
Workflow and Sequences section in 
the Method Editor.

a If the Method Editor is not visible, click View 
> Method Editor. 

b Click Method Automation > Workflow and 
Sequences in the Method Editor window. 

• You can instead click the Method 
Editor button, , on the main 
toolbar.

3 Select the appropriate workflow. a Select Released Glycans for the Workflow.
b Enter Example in the Glycan group. 
c Select Glycans_mAb_AM_PCD.cdb as the 

Target glycan source.
d Clear the Require RT match if database 

contains a RT for the target glycan check 
box.

• The Released Glycans workflow 
automatically runs the Find 
Glycans algorithm.

• The Glycan group is used to 
organize the results in the Results 
Compare window.

4 Save the method. • Click Method > Save.
• If needed, enter a reason for the change in 

the Reason for Change dialog box.

• The administrator can set up a 
project to require you to enter a 
reason for a change to a method 
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5 Run the method workflow or run 
method automation.

• Click Method > Run Method Workflow.
• Click Method > Run Method Automation 

(Workflow + Reports).
• Click on the Method Editor toolbar 

when the Workflow and Sequences section 
is showing.

• Reprocess the sample. See “Exercise 11. 
Reprocess Samples” on page 62.

• Method Automation first runs the 
method workflow and then 
extracts additional 
chromatograms, generates a 
biomolecule report, and exports 
results.

• The Workflow column is set to 
“Released Glycans”. The Relative 
Quantitation Histograms window 
and the Results Compare window 
contain results.

6 (optional) Review the printed 
Biomolecule reports.

• If you clicked Run Method Automation 
(Workflow + Reports), then a report is 
generated automatically.

• You can click File > Print > Biomolecule 
Report to generate a report for the current 
sample.

• You set report options in the 
Method Editor window in the 
Method Automation > Reports 
section.

• If you are creating a report 
interactively, you specify some of 
these parameters in the Print 
Biomolecule Report dialog box.

• When you run one of the 
workflows, the Workflow column is 
updated in the Sample Table. If you 
entered a Glycan Group You can 
also see the Glycan Group column 
in the Sample Table.

Steps Detailed Instructions Comments
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7 Review the results in the Results 
Compare window.

a Click the Results Compare window.
b Click the Released Glycans tab.
c Note that RSD (%) is empty because only 

one sample is selected. If you select two or 
more samples and they belong to the same 
Glycan Group, then the results are shown in 
the same table. If the same glycan is in 
multiple samples, then the RSD (%) is 
calculated.

• For Released Glycans workflow, 
the software uses the Use for 
%Quant check box in the 
Biomolecules window.

• The Results compare window is 
tabbed with the Relative 
Quantitation Histograms window. 

Steps Detailed Instructions Comments
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8 Save the results for the current data 
file and close all data files.

a Click File > Save Results.
b If needed, enter or select a reason in the 

Reason for Change dialog box. Click OK.
c Click File > Close All.
d Click No to save results.

• You need to save results as you 
process your data files. You can 
only save results that have been 
processed with the current 
method. If you change the method 
after generating results, then you 
need to generate results again.

Steps Detailed Instructions Comments
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Exercise 6. Automated Released Glycans Workflow
Oligonucleotide Workflow - Target Plus 
Impurities

The steps outlined below show the workflow for Oligonucleotides with the Target 
Plus Impurities experiment with MassHunter BioConfirm.

Step 1 - Open the data file of interest and select the Oligos - Target Plus 
Impurities layout.
Step 2 - Open a BioConfirm method or create a new one.
Step 3 - Edit oligonucleotide sequences if necessary in the Sequence Manager 
program:
• Add or edit the sequence text
Step 4- Select Oligonucleotides as the Workflow on the Workflow and 
Sequences tab.
Step 5- Select Target Plus Impurities as the Experiment.
Step 6- Select the sequence or mass that you want to use.
If the sequence you want to select is not in the method or Select Sequences 
dialog box, then Import or create an oligonucleotide sequence.
Step 7 - Select the Mods and Profiles on the Workflow and Sequences tab.
Step 8 - Select the Matching Rules.
Step 9 - Run the Method Workflow.
Step 10 - Review the results which are shown in these windows:
Sample Chromatogram Results
Biomolecule MS Chromatogram
Biomolecules table
Biomolecule Identification Results
Biomolecule MS Spectrum
Deconvolution Results
Oligos - Impurity List
Results Compare
Relative Quantitation Histograms
Step 11 - Print report.
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Exercise 7. Interactive Oligonucleotides - Target Plus Impurities Workflow
Exercise 7. Interactive Oligonucleotides - Target Plus 
Impurities Workflow

This exercise shows you how to find oligonucleotides interactively with the 
Target Plus Impurities experiment. If you select the Oligonucleotides workflow 
with the Target Plus Impurities experiment, the Find by Oligonucleotide 
Deconvolution algorithm or the Find by Formula (Oligos) algorithm runs. See 
“Before you start” on page 3. You can run the Match Sequences algorithm on 
results from Find by Oligonucleotide Deconvolution, but that is not shown in this 
exercise.

Steps Detailed Instructions Comments

1 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select the BioConfirmOligosTPI-Default.m 

folder.
c Click Open.

• The parameters in the 
BioConfirmOligosTPI-Default.m 
method are a good starting point 
for the Target Plus Impurities 
experiment.

2 Open the example sample file. a If needed, click File > Open Data File.
b Select Oligo_40mer_MS_1.d.
c Click Open.

• The TIC is automatically 
displayed in the Sample 
Chromatogram Results window.

3 Load the Target Plus Impurities 
layout.

• Click Oligos - Target Plus Impurities Layout in 
the main toolbar.

4 Review the parameters in the 
Oligonucleotides - Target Plus 
Impurities > Deconvolute (Oligos) 
section in the Method Editor 
window.

a Select Oligonucleotides - Target Plus 
Impurities > Deconvolute (Oligos) in the 
Method Editor window.

b Click the Match Tolerances tab.
c Select Da and enter 1.0 for the Tolerance.
d Click the Peak Filters tab.
e Mark Limit (by height) to the largest and enter 

5.
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5 Run the Find by Oligonucleotide 
Deconvolution algorithm.

a Click  on the Method Editor toolbar to start 
the biomolecule search. 

b When processing is complete, review the 
results in the Biomolecules window.

6 Save the method. a Click Method > Save As.
b Type the File name iii_OligosFOD.m, where iii 

represents your initials. 
c Click Save. 
d If needed, enter a reason on the Reason for 

Change dialog box. Click OK.

7 Review the results. • When you run the Find by Oligonucleotide 
Deconvolution algorithm, the Oligos - Impurity 
List and the Biomolecule Identification Results 
window are empty. 

• Several columns have been 
changed from the default Oligos - 
Target Plus Impurities Layout.

8 Save the results. a Click File > Save Results to save your results 
to the data file folder.

b If needed, enter a reason for the change.

• You can also click  to save 
results.

Steps Detailed Instructions Comments
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9 Select parameters in the Method 
Automation > Workflow and 
Sequences section in the Method 
Editor window.
• Select 40mer as the Sequence.
• Select /K/ and /Na/ for the Mods 

and Profiles.
•

a Select Method Automation > Workflow and 
Sequences in the Method Editor window.

b Select Oligonucleotides.
c Select Target Plus Impurities as the 

Experiment.
d Click the  button next to the 

Sequences/Masses parameter. The Select 
Sequences dialog box opens.

e Double-click 40mer. If 40mer is not available, 
click Add.

f Select Oligo_40mer_MS.psq and click Open.
g Verify that the 40mer sequence is in the 

Selected list. 
h Click OK.
i Click the  button next to the Mods and 

Profiles parameter. 
j Select /K/ and /Na/ from the Available list.
k Click OK.
l Click  next to Matching Rules.
m Mark 5’-Truncation with linker and 

3’-Truncation with linker. Enter 5 for 
Maximum allowed for each. Click OK.

• You need to select a sequence 
before you can run the Find by 
Formula (Oligos) algorithm.

• You need to be very selective with 
the choices for the Mods and 
Profiles and for the Matching 
Rules. These choices can limit 
the size of the database and 
significantly affect the processing 
time.

10 Review the parameters in the 
Oligonucleotides - Target Plus 
Impurities > Find by Formula (Oligos) 
section in the Method Editor 
window.

a Select Oligonucleotides - Target Plus 
Impurities > Find by Formula (Oligos) in the 
Method Editor window.

b Review the parameters.

• You can limit the number of 
biomolecules found by adding 
filters.

Steps Detailed Instructions Comments
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11 Run the Find by Formula (Oligos) 
algorithm.

a Click  on the Method Editor toolbar to start 
the biomolecule search. 

b When processing is complete, review the 
results in the Biomolecules window.

• You can instead click Find and 
Identify > Find by Formula 
(Oligos).

12 Save the method for use in Exercise 
8.

a Click Method > Save As.
b Type the File name iii_OligosTPI.m, where iii 

represents your initials. 
c Click Save. 
d If needed, enter a reason on the Reason for 

Change dialog box. Click OK.

• 4 compounds and 2 impurities 
were found when running the 
Find by Formula (Oligos) 
algorithm.

13 Save the results. a Click File > Save Results to save your results 
to the data file folder.

b If needed, enter a reason for the change.

• You can also click  to save 
results.

Steps Detailed Instructions Comments
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Exercise 8. Automated Oligonucleotides - Target Plus 
Impurities Workflow

This exercise guides you through the setup of a worklist to automatically run the 
Oligonucleotides - Target Plus Impurities workflow.

If you select the Oligonucleotides - Target Plus Impurities workflow, the Find by 
Oligonucleotide Deconvolution algorithm or the Find by Formula (Oligos) 
algorithm runs.

Steps Detailed Instructions Comments

1 Open the method. a Click Method > Open.
b Select the iii_OligosTPI.m folder.
c Click Open.

• This method was created in 
Exercise 7 (iii represents your 
initials).

2 Display the Method Automation > 
Workflow and Sequences section in 
the Method Editor.

a If the Method Editor is not visible, click View 
> Method Editor. 

b Click Method Automation > Workflow and 
Sequences in the Method Editor window. 

• You can instead click the Method 
Editor button, , on the main 
toolbar.
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3 Select the appropriate workflow. a Select Method Automation > Workflow and 
Sequences in the Method Editor window.

b Select Oligonucleotides.
c Select Target Plus Impurities as the 

Experiment.
d Click the  button next to the 

Sequences/Masses parameter. The Select 
Sequences dialog box opens.

e Double-click 40mer. If 40mer is not 
available, click Add.

f Select Oligo_40mer_MS.psq and click 
Open.

g Verify that the 40mer sequence is in the 
Selected list. 

h Click OK.
i Click the  button next to the Mods 

and Profiles parameter. 
j Select /K/ and /Na/ from the Available list.
k Click OK.
l Click  next to Matching Rules.
m Mark 5’-Truncation with linker and 

3’-Truncation with linker. 
n Enter 5 for Maximum allowed for each.
o Click OK.

• The Matching Rules parameter 
shows the rules that are marked, 
and it shows the Maximum 
allowed in parentheses after the 
rule.

Steps Detailed Instructions Comments
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4 Verify Confirmation Options. a Select Method Automation > Confirmation 
Options in the Method Editor window.

b Click the Oligonucleotides tab.
c Review the Purity confirmation values.
d Verify that the Workflow transition is set 

correctly.

• The Target Plus Impurities 
experiment switches between two 
algorithms at the mass that is 
selected in this tab. See the online 
Help for more information.

5 Save the method. • Click Method > Save.
• If needed, enter a reason for the change in 

the Reason for Change dialog box.

• The administrator can set up a 
project to require you to enter a 
reason for a change to a method 

6 Run the method workflow or run 
method automation.

• Click Method > Run Method Workflow.
• Click Method > Run Method Automation 

(Workflow + Reports).
• Click on the Method Editor toolbar 

when the Workflow and Sequences section 
is showing.

• Reprocess the sample. See “Exercise 11. 
Reprocess Samples” on page 62.

• Method Automation first runs the 
method workflow and then 
extracts additional 
chromatograms, generates a 
biomolecule report, and exports 
results.

• The Workflow column is set to 
“Oligonucleotides”. The Oligos - 
Impurity List window, the 
Deconvolution Results window, 
and the Results Compare window 
contain results.

7 (optional) Review the printed 
Biomolecule reports.

• If you clicked Run Method Automation 
(Workflow + Reports), then a report is 
generated automatically.

• You can click File > Print > Biomolecule 
Report to generate a report for the current 
sample.

• You set report options in the 
Method Editor window in the 
Method Automation > Reports 
section.

• If you are creating a report 
interactively, you specify some of 
these parameters in the Print 
Biomolecule Report dialog box.

• When you run one of the 
workflows, the Workflow column is 
updated in the Sample Table. You 
can also see the Experiment 
column in the Sample Table.

Steps Detailed Instructions Comments
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8 Review the results in the Results 
Compare window.

a Click the Results Compare window.
b Click the Oligos - Target Plus Impurities 

tab.
c Note that RSD (%) is empty because only 

one sample is selected. If you select two or 
more samples and they use the same 
sequence, then the results are shown in the 
same table. 

• For Oligonucleotides - Target Plus 
Impurities workflow, the software 
uses the Use for %Quant check 
box in the Biomolecules window.

Steps Detailed Instructions Comments
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9 Save the results for the current data 
file and close all data files.

a Click File > Save Results.
b If needed, enter or select a reason in the 

Reason for Change dialog box. Click OK.
c Click File > Close All.
d Click No to save results.

• You need to save results as you 
process your data files. You can 
only save results that have been 
processed with the current 
method. If you change the method 
after generating results, then you 
need to generate results again.

• If you try to save results, you may 
get this message “Result set 
exceeds operating system limits.” 
You get this message if you have 
too many biomolecules or 
impurities. See the online Help for 
more information.

Steps Detailed Instructions Comments
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Oligonucleotide Workflow - Sequence 
Confirmation

The steps outlined below show the workflow for Oligonucleotides with the 
Sequence Confirmation experiment with MassHunter BioConfirm.

Step 1 - Open the data file of interest and select the Oligonucleotide - Sequence 
Confirmation layout.
Step 2 - Open a BioConfirm method or create a new one.
Step 3 - Edit oligonucleotide sequences if necessary in the Sequence Manager 
program:
• Add or edit the oligonucleotide sequence text
• Apply or edit modifications
Step 4- Select Oligonucleotides as the Workflow on the Workflow and 
Sequences tab.
Step 5- Select Sequence Confirmation as the Experiment.
Step 6- Select the sequence or sequences that you want to use.
If the sequence you want to select is not in the method or Select Sequences 
dialog box, then Import or create an oligonucleotide sequence.
Step 9 - Run the Method Workflow.
Step 10 - Review the results which are shown in these windows:
Sample Chromatogram Results
Biomolecules table
Biomolecule Identification Results
Biomolecule Fragment Spectrum
Fragment Confirmation Ladder
Step 11 - Print report.
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Exercise 9. Interactive Oligonucleotides - Sequence 
Confirmation Workflow

This exercise shows you how to find oligonucleotides interactively with the 
Sequence Confirmation experiment.

If you select the Oligonucleotides workflow with the Sequence Confirmation 
experiment, the Find Oligonucleotides Fragments algorithm runs. See “Before 
you start” on page 3.

Steps Detailed Instructions Comments

1 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select the BioConfirmOligosSC-Default.m 

folder.
c Click Open.

• The parameters in the 
BioConfirmOligosSC-Default.m 
method are a good starting point 
for the Sequence Confirmation 
experiment.

2 Open the example sample file. a If needed, click File > Open Data File.
b Select 40mer_MSMS_14CS_14CE.d.
c Click Open.

• The TIC is automatically 
displayed in the Sample 
Chromatogram Results window.

3 Load the Oligonucleotides - 
Sequence Confirmation layout.

• Click Oligonucleotides - Sequence 
Confirmation Layout in the main toolbar.

4 Review the parameters in the Find 
Glycans section in the Method Editor 
window.

a Select Method Automation > Workflow and 
Sequences in the Method Editor window.

b Select Oligonucleotides.
c Select Sequence Confirmation as the 

Experiment.
d Click the  next to the Sequences 

parameter.
e Select Oligo_40mer_MSMS and click OK.
f Select Oligos - Sequence Confirmation > 

Find Oligo Fragments in the Method Editor 
window.

g Review parameters on each tab.

• You can change the default 
parameters as described in the 
next steps.

• For some data files, you will need 
to use different parameters as 
described in the online Help.

5 Run the Find Oligonucleotide 
Fragments algorithm.

a Click  on the Method Editor toolbar to start 
the biomolecule search. 

b When processing is complete, review the 
results in the Biomolecules window.

• You can instead click Find and 
Identify > Find Oligonucleotide 
Fragments.

• By default, all results are selected 
after you run this algorithm.
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6 Save the method for use in Exercise 
10.

a Click Method > Save As.
b Type the File name 

iii_40merMSMS_OligosSC.m, where iii 
represents your initials. 

c Click Save. 
d If needed, enter a reason on the Reason for 

Change dialog box. Click OK.

Steps Detailed Instructions Comments
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7 Review the results. a In the Biomolecules window, click the header 
of the Height column to sort the table by this 
column. If necessary, click the header again 
so that the largest heights are at the top of the 
table. 

b Select the first biomolecule in the 
Biomolecules window.

c Click the Biomolecule Identification Results 
tab. The Biomolecules Identification Results 
window is tabbed with the Biomolecules 
window. 

d When you open the window, the window 
displays the results for the first biomolecule 
that is selected in the Biomolecules window. 

• Several changes were made to 
the default layout for the image 
below. Several columns were 
hidden in the Sample Table, and 
Auto fit was cleared in the 
Fragment Confirmation Ladder.

• The Fragment Confirmation 
Ladder shows the fragments for 
each of the nucleosides in the 
selected sequence. The selected 
biomolecule is shown as an 
empty circle on one of the limbs 
in the ladder. 

• See the online Help for more 
information on this window.

8 Save the results a Click File > Save Results to save your results 
to the data file folder.

b If needed, enter a reason for the change.

• You can also click  to save 
results.

Steps Detailed Instructions Comments
Agilent MassHunter BioConfirm Software Introduction Guide 57



Oligonucleotide Workflow - Sequence Confirmation
Exercise 10. Automated Oligonucleotides - Sequence Confirmation Workflow
Exercise 10. Automated Oligonucleotides - Sequence 
Confirmation Workflow

This exercise guides you through the setup of a worklist to automatically run the 
Oligonucleotides - Sequence Confirmation workflow.

If you select the Oligonucleotides - Sequence Confirmation workflow, the Find 
Oligonucleotide Fragments algorithm runs.

Steps Detailed Instructions Comments

1 Open the method. a Click Method > Open.
b Select the iii_40merMSMS_OligosSC.m 

folder.
c Click Open.

• This method was created in 
Exercise 9 (iii represents your 
initials).

2 Display the Method Automation > 
Workflow and Sequences section in 
the Method Editor.

a If the Method Editor is not visible, click View 
> Method Editor. 

b Click Method Automation > Workflow and 
Sequences in the Method Editor window. 

• You can instead click the Method 
Editor button, , on the main 
toolbar.

3 Select the appropriate workflow. a Select Oligonucleotides for the Workflow.
b Select Sequence Confirmation for the 

Experiment. 
c Click the  next to the Sequences 

parameter.
d Select Oligo_40mer_MSMS and click OK.

• You cannot enter a mass if you 
select the Sequence Confirmation 
experiment.

4 Save the method. • Click Method > Save.
• If needed, enter a reason for the change in 

the Reason for Change dialog box.

• The administrator can set up a 
project to require you to enter a 
reason for a change to a method 
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5 Run the method workflow or run 
method automation.

• Click Method > Run Method Workflow.
• Click Method > Run Method Automation 

(Workflow + Reports).
• Click on the Method Editor toolbar 

when the Workflow and Sequences section 
is showing.

• Reprocess the sample. See “Exercise 11. 
Reprocess Samples” on page 62.

• Method Automation first runs the 
method workflow and then 
extracts additional 
chromatograms, generates a 
biomolecule report, and exports 
results.

• The Workflow column is set to 
“Oligonucleotides”, and the 
Experiment is set to “Sequence 
Confirmation”.

6 (optional) Review the printed 
Biomolecule reports.

• If you clicked Run Method Automation 
(Workflow + Reports), then a report is 
generated automatically.

• You can click File > Print > Biomolecule 
Report to generate a report for the current 
sample.

• You set report options in the 
Method Editor window in the 
Method Automation > Reports 
section.

• If you are creating a report 
interactively, you specify some of 
these parameters in the Print 
Biomolecule Report dialog box.

• When you run one of the 
workflows, the Workflow column is 
updated in the Sample Table. 

Steps Detailed Instructions Comments
Agilent MassHunter BioConfirm Software Introduction Guide 59



Oligonucleotide Workflow - Sequence Confirmation
Exercise 10. Automated Oligonucleotides - Sequence Confirmation Workflow
Steps Detailed Instructions Comments
60 Agilent MassHunter BioConfirm Software Introduction Guide



Oligonucleotide Workflow - Sequence Confirmation
Exercise 10. Automated Oligonucleotides - Sequence Confirmation Workflow
7 Review the results in the Fragment 
Confirmation Ladder window.

a Click the Fragment Confirmation Ladder 
window.
• If a nucleotide has a fragment that 

confirms it, the nucleotide is shown in 
black. If no fragment confirms the 
nucleoside, it is shown in gray. 

• If no fragments are on a line between two 
nucleosides, the line is not drawn.

• Each line can have 9 possible dots to 
represent each of the fragment types 
expected to be found at each location.

• The dots on the bottom limb apply to the 
nucleoside to the left of the line.

• The dots on the upper limb apply to the 
nucleoside to the right of the line.

• If a fragment is found in the results, a dot 
appears at the correct location on the 
fragment confirmation ladder.

• The selected biomolecule or 
biomolecules in the Biomolecule table are 
displayed as an open circle in the 
Fragment Confirmation Ladder.

• If multiple data files are selected, the dots 
are shown in different colors.

• If you hover over a fragment dot, a tooltip 
shows you which biomolecules show 
that fragment.

• If you mark the Auto fit check box, 
all of the nucleosides are visible in 
one row, if possible.

• If you select multiple data files that 
were processed with the same 
sequence, the results of all the 
selected data files are shown in the 
Fragment Confirmation Ladder (up 
to a maximum of 10 data files). 
The dots for each data file are 
shown on the same fragment 
confirmation ladder (one color for 
each data file). If the same 
fragment is confirmed in multiple 
data files, then the dot has the 
color for Multiple fragments.

• The percentage shown in the title 
bar for the window shows the 
cumulative results for all selected 
data files.

8 Save the results for the current data 
file and close all data files.

a Click File > Save Results.
b If needed, enter or select a reason in the 

Reason for Change dialog box. Click OK.
c Click File > Close All.
d Click No to save results.

• You need to save results as you 
process your data files. You can 
only save results that have been 
processed with the current 
method. If you change the method 
after generating results, then you 
need to generate results again.

Steps Detailed Instructions Comments
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Exercise 11. Reprocess Samples

This exercise shows you how to reprocess samples in the Sample Table. You can 
quickly check the Confirmation Status of each sample and determine if you need 
to reprocess the sample.

Steps Detailed Instructions Comments

1 Open several data files. a Click File > Open Data File.
b Select these example files: NIST mAb 

1.d, NIST mAb 2.d, NIST mAb 
Digest.d, NIST mAb Digest2.d, 
ReleasedGlycans1.d, and 
ReleasedGlycans2.d.

c Mark the Load result data check box.
d Click Open.

• To select multiple files, click the first 
file. Then, press Shift and click the last 
file.

• In Networked Workstation mode, you 
can select which version of the results 
to open when you open a data file. See 
“Exercise 18. Open results using 
versions” on page 88.

2 Review results in the Sample Table 
window.

a Look at the Confirmation Status 
column.

• If you saved results, the table contains 
information on confirmation.
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3 Review values in Method Automation 
> Confirmation Options.

a Click View > Method Editor, if 
necessary.

b Select Method Automation > 
Confirmation Options.

c Click the Intact Protein tab.
d Review selection for the Intact Protein 

match found but not for the most 
abundant peak option.

e Click the Protein Digest tab.
f Review selection for the Protein is 

partially confirmed when sequence 
coverage is >= option.

• These tabs explain what it means to be 
Confirmed and Partially confirmed.

• You are not changing these options. 
You are only seeing what the software 
checks to determine if the protein is 
confirmed.

• The Confirmation Status is always 
“Undetermined” if the Workflow is 
Released Glycans.

• The Oligonucleotides tab will be 
reviewed in a different exercise.
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4 Reprocess the ReleasedGlycans2.d 
data file.

a In the Sample Table, click the row 
containing ReleasedGlycans2.d.

b Click Method > Open.
c Select the iii_ReleasedGlycans-

InstantPC.m folder.
d Click Open.
e Click the  button to open the 

Reprocess Sample dialog box.
f Select Released Glycans for the 

workflow.
g Enter Example for the Glycan group.
h Select Glycans_mAb_AM_PCD.cdb 

for the Target glycan source.
i Click Reprocess.

• To reprocess a sample, you need to 
first load the correct method and then 
complete the Reprocess Sample 
dialog box.

• You can also double-click the Sample 
Table row to open the Reprocess 
Sample dialog box.

• You can either use the current method, 
or if you have previously saved results, 
you can use the sample result method.

5 Save the results for the samples that 
you reprocessed.

a Click File > Save Results.
b Click Save.
c If needed, enter or select a reason in 

the Reason for Change dialog box. 
Click OK.

Steps Detailed Instructions Comments
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Exercise 12. Use Result Review mode

This exercise shows you how to use the Result Review mode. When this mode is 
enabled, you cannot edit a method. You also cannot run the algorithms in the 
Find and Identify menu.

Steps Detailed Instructions Comments

1 Enable Result Review mode. • Click Configuration > Enable Result 
Review (Disables Method Editing).

• You can toggle this mode off by 
clicking this same command again.

2 Review results in Sample Table 
window.

• All of the options in this window are 
available except for the Run Method 
Workflow button. You can still 
reprocess samples.
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3 Review and compare the 
ReleasedGlycans1.d and 
ReleasedGlycans2.d data files.

a In the Sample Table, click the row 
containing ReleasedGlycans1.d.

b Press the Shift key and click the row 
containing ReleasedGlycans2.d.

c Review the results in the Results 
Compare window. The RSD (%) 
column has been calculated for 
glycans that are in both samples.

d Review the Relative Quantitation 
Histograms window. 

• You can visually compare the relative 
quantitation results for different 
glycans.

• Right-click and drag on either axis to 
zoom in on that axis.

• Click and drag to scroll along the axis 
after you have zoomed.

Steps Detailed Instructions Comments
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4 Review and compare the NIST mAb 
Digest.d and NIST mAb Digest2.d data 
files.

a In the Sample Table, click the row 
containing NIST mAb Digest.d.

b Press the Shift key and click the row 
containing NIST mAb Digest2.d.

c Click the Protein Digest Layout button 
in the main toolbar.

d Review the results in the Results 
Compare window. The RSD (%) 
column has been calculated for many 
modifications that are in both 
samples.

• The Results Compare window is not 
visible by default in the Protein Digest 
layout. Click View > Results Compare 
to open the window.

e Review the results in the Sequence 
Coverage Map window. A legend is 
added to the top of the window and 
the lines under the sequence are color 
coded to show which sample is 
described.

• See the online Help for information on 
the meaning for the text and for the 
lines.
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f Review the results in the Peptide 
Relative Quantitation Results window. 
The Location C147 [B/D] has multiple 
rows because this location is in both 
samples.

• For Protein Digest workflows, you 
mark the Use for %Quant check box in 
the Peptide Relative Quantitation 
Results window.

Steps Detailed Instructions Comments
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Exercise 13. Use Report Builder

This exercise shows you the program that you use to modify report templates. 
You can use Report Builder to modify the templates used to generate a 
Biomolecule report.

Steps Detailed Instructions Comments

1 Open Report Builder program. a Double-click the Control Panel icon on 
the desktop. 

b Click Projects in the left pane.
c Select a project.
d On the ribbon in the Report Builder 

group, click Report Builder > Start 
Report Builder.

Or you can do the following:
a Click Agilent MassHunter Report 

Builder > Report Builder 11.1.
b Select a project to use.
c Click OK.

• You can also start the Report Builder 
program when you click one of the Edit 
button next to a template in the 
Method Automation > Reports > 
Template tab. These Edit buttons are 
only available if you click Configuration 
> Show Advanced Settings.
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2 Open an existing template. a Click File > Open > Browse.
b Select 

IntactProteinReport.template.xml 
and click Open.

a Click File > Save As > Browse.
b Enter a file name and click Save.
c If needed, enter a reason and click OK.

• Report templates are installed in the 
Report Templates\BioConfirm folder 
in the project.

Steps Detailed Instructions Comments

Agilent recommends that you 
do not modify the default 
templates. Instead, make a copy 
of the template and modify the 
copy. 
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3 Review the template in Report Builder. a Click an item in the template. Notice 
that the right pane changes.

b Click the title of the report.
c In the right pane, click Localized Text 

in the Content section.
d Click the ... button. The Localized Text 

dialog box opens.
e Click the Header_Center.
f Enter My Intact Protein Report.
g Click OK.

• The left pane shows the template. The 
right pane shows the parameters for 
the current selection.

• You can make many different changes 
to the report. This exercise only shows 
you one possibility. Press F1 to access 
the online Help to learn more about 
customizing a report template.
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4 Save the template. a Click File > Save.
b If needed, enter a reason and click OK.
c Close the Report Builder program.

• You can instead click File > Save, and 
the file is saved to the current report 
template. Agilent recommends that 
you do not modify the default 
templates.

Steps Detailed Instructions Comments
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5 Use this new template in a method. a Open the Method Editor window. Click 
View > Method Editor if it is not visible.

b Select Method Automation > Reports.
c Click the Templates tab.
d Select the changed report for the 

corresponding report template type. In 
this example, the Intact Protein report 
template was modified.

• Different reports use different report 
templates. If you modified an Intact 
Protein report template, then you 
select the modified template for the 
Intact Protein report template.

• When you print a biomolecule report, 
the report template corresponding to 
the selected workflow is used.

• If the modified template is not shown 
in the list, you may need to switch to a 
different section in the Method Editor 
window and return. This action usually 
refreshes the list of report templates.
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6 Print a Biomolecule report. a Click File > Print > Biomolecule 
Report.

b Select a data file that was processed 
with the Intact Protein workflow.

c Mark the Print preview check box.
d Click OK.

• When you print a biomolecule report, 
the report template corresponding to 
the selected workflow is used.

Steps Detailed Instructions Comments
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Exercise 14. Determine Protein Molecular Weight

This exercise shows you how to open a data file, extract spectra, deconvolute, 
and view results. Deconvolution software does charge state deconvolution of 
mass spectra of large molecules with high charge states, such as proteins. See 
“Before you start” on page 3.

Steps Detailed Instructions Comments

1 Open the data file. a Click File > Open Data File.
b Locate the NIST mAb 1.d folder.
c Clear the Load Result check box.
d Click Open.

• The TIC is automatically displayed in 
the Sample Chromatogram Results 
window.

2  Extract a peak spectrum. a Select a range around the peak at 2.1 
minutes.

b Double-click this range.

• To select a range, click one side of the 
peak and drag to the other side of the 
peak.

3 Open the default Intact Protein 
method and open the Deconvolute 
(Protein) Method Editor section.

a Click Method > Open.
b Select 

BioConfirmIntactProtein-Default.m.
c Click View > Method Editor.
d Select Intact Protein > Deconvolute 

(Protein).

• The commands in the View menu 
toggle whether or not a window is 
visible. If the command is shown in 
blue and the button has an orange box 
around it, then the window is currently 
visible.
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4 Select Maximum Entropy as the 
deconvolution algorithm.

• On the Deconvolution tab of the 
Deconvolute (Protein) section of the 
Method Editor, verify that Maximum 
Entropy is selected for Deconvolution 
algorithm.

5 Verify that the Mass range is 
automatically detected.

• Verify that the Automatic mass range 
detection check box is marked.

• If you clear this check box, then you 
need to manually enter the Mass range 
which can vary for different intact 
proteins.

6 Set the Mass step to 1. • Enter 1 for the Mass step.

7 Select the extracted MS peak 
spectrum.

• Click the spectrum in the Biomolecule 
MS Spectrum window.

8 Deconvolute the spectrum. • Right-click the Biomolecule MS 
Spectrum window and click 
Deconvolute > Protein to start the 
deconvolution process.

• You can also click the arrow next to the 
run button in the Method Editor toolbar 
and select Deconvolute (Protein).

Steps Detailed Instructions Comments
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9 Review deconvolution results. • The results appear in the 
Deconvolution Results window and the 
Biomolecules window.

• For information on changing the 
display of data in the Deconvolution 
Results window, see online Help.

• To compare two deconvoluted 
spectra, select the spectra of interest; 
then, click the Create Mirror Plot 
button, , on the Deconvolution 
toolbar. If necessary, click View > 
Deconvolution Mirror Plot. The 
spectra are displayed in the 
Deconvolution Mirror Plot Results 
window. See “Exercise 16. Use the 
Mirror Plot window” on page 82 for 
more information.

10 View peak information. a Click the spectrum in the 
Deconvolution Results window to 
select it.

b Click the Spectrum Peak List button 
( ) . 

c Click the Max Abund column heading 
to sort results by abundance.

d Click  in the toolbar in the 
Deconvolution Results window.

e Select Mass for the first Peak label 
and click OK.

f Click the Spectrum Peak List button 
( ) on the Deconvolution Results 
toolbar to close the peak list tab.

• Mass, Abundance, and Fit score are 
listed for each peak in the spectrum. 

• You can change the size of the 
graphics pane and the table pane in the 
Deconvolution Results window. Select 
the line between them and drag it to 
the right or left.

• In the Deconvoluted Spectra Display 
Options dialog box, you can select the 
labels to use on a deconvoluted 
spectrum. 

11 Save the results. a Click File > Save Results.
b If needed, enter a reason and click OK.
c Click Save.

12 Save the method to 
iii_Deconvolution_MaxEnt.m where iii 
are your initials

a Click Method > Save As.
b Enter iii_Deconvolution_MaxEnt.m for 

the method name.
c Click Save.

Steps Detailed Instructions Comments
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Exercise 15. Calculate DAR

This section shows how to calculate DAR for both a non-reduced and a reduced 
data file..

Steps Detailed Instructions Comments

1 Open the DAR_Sample_Intact.d and 
the DAR_Sample_Reduced.d data files.

a Click File > Open Data File.
b Locate the DAR_Sample_Intact.d and 

the DAR_Sample_Reduced.d folders.
c Clear Load Result Data.
d Click Open.
e Click Intact Protein Layout in the 

toolbar.

• The TIC is automatically displayed in 
the Sample Chromatogram Results 
window.

• The Intact Protein layout shows the 
Deconvolution Results window.

2 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select 

BioConfirmIntactProtein-Default.m
c Click Open.

3 Open the Deconvolute (Protein) 
Method Editor section.

• Select Deconvolute (Protein) from the 
Intact Protein section of the Method 
Editor.

If the Method Editor window is not visible, 
click View > Method Editor to display it.
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4 Select the deconvolution algorithm. 
• Use Maximum Entropy.
• Use 20000 - 60000 mass range.
• Do not use the limited m/z range.

a On the Deconvolution tab of the 
Deconvolute (Protein) section of the 
Method Editor, select Maximum 
Entropy as the Deconvolution 
algorithm.

b Clear the Automatic mass range 
detection check box. 

c Enter 20000 - 60000 for the Mass 
range.

d Clear the Use limited m/z range check 
box.

• For more information on these 
parameters, press F1 to open the 
online Help.

5 Use the default settings for Maximum 
Entropy deconvolution.

• Click the Maximum Entropy tab to 
review settings.

6 Set the time range for extracting 
spectra to 6 to 8 minutes.

a On the Extract Spectrum (MS) tab of 
the Intact Protein section of the 
Method Editor, click Time Range(s).

b Enter 6 as the Start and 8 as the Stop.

7 Set the workflow parameters for the 
reduced Condition.

a On the Workflow and Sequences tab 
of the Method Automation section of 
the Method Editor, select Intact 
Protein.

b Select reduced as the Condition.
c Enter 23439, 50594 for 

Sequences/Masses.
d Mark the Calculate Drug-to-Antibody 

Ratio (DAR) check box.
e Enter 957.5 as the Drug + linker 

mass.

• For a method with reduced as the 
Condition, you enter the Reduced DAR 
Light Chain, Reduced DAR Heavy 
Chain as the Sequences/Masses.

Steps Detailed Instructions Comments
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8 Save the method. a Click Method > Save As.
b Type the File name 

iii_DAR_Reduced.m, where iii 
represents your initials. 

c Click Save.
d If needed, enter a reason in the 

Reason for Change dialog box.
e Click OK.

• The administrator can set up a project 
to require you to enter a reason for a 
change to a method 

9 Run the method workflow on the 
DAR_Sample_Reduced.d file.

a Click Method > Run Method 
Workflow, or click Run Method 
Workflow in the toolbar in the Method 
Editor window.

b Select DAR_Sample_Reduced.d and 
click OK.

10 Review deconvolution results. • The results appear in the 
Deconvolution Results window and in 
the Sample Table window.

• Deconvoluted spectra are added for 
the light chain and for the heavy chain.

• The DAR value is added to the Sample 
table.

11 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select 

BioConfirmIntactProtein-Default.m
c Click Open.

12 Select the deconvolution algorithm. 
• Use Maximum Entropy.
• Use 20000 - 60000 mass range.
• Do not use the limited m/z range.

a On the Deconvolution tab of the 
Deconvolute (Protein) section of the 
Method Editor, select Maximum 
Entropy as the Deconvolution 
algorithm.

b Clear the Automatic mass range 
detection check box. 

c Enter 20000 - 60000 for the Mass 
range.

d Clear the Use limited m/z range check 
box.

• For more information on these 
parameters, press F1 to open the 
online Help.

Steps Detailed Instructions Comments
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13 Set the workflow parameters for the 
non-reduced Condition.

a On the Workflow and Sequences tab 
of the Method Automation section of 
the Method Editor, select Intact 
Protein.

b Select non reduced as the Condition.
c Enter 148057.5 for 

Sequences/Masses.
d Mark the Calculate Drug-to-Antibody 

Ratio (DAR) check box.
e Enter 974.5 as the Drug + linker 

mass.

• For a method with non reduced as the 
Condition, you enter the initial Dar 0 
mass as the Sequences/Masses.

14 Save the method. a Click Method > Save As.
b Type the File name 

iii_DAR_NonReduced.m, where iii 
represents your initials. 

c Click Save.
d If needed, enter a reason in the 

Reason for Change dialog box.
e Click OK.

• The administrator can set up a project 
to require you to enter a reason for a 
change to a method 

15 Run the method workflow on the 
DAR_Sample_Intact.d file.

a Click Method > Run Method 
Workflow, or click Run Method 
Workflow in the toolbar in the Method 
Editor window.

b Select DAR_Sample_Intact.d and click 
OK.

16 Review deconvolution results. • The results appear in the 
Deconvolution Results window and the 
Sample Table window.

• A deconvoluted DAR spectrum is 
added.

• The DAR value is added to the table.

17 Save the results. a Click File > Save Results.
b If needed, enter a reason and click OK.
c Click Save.

Steps Detailed Instructions Comments
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Exercise 16. Use the Mirror Plot window

This section shows how to display a Mirror Plot of two deconvoluted 
biomolecules.

Steps Detailed Instructions Comments

1 Open the NIST mAb 1.d data file. a Click File > Open Data File.
b Locate the NIST mAb 1.d folder.
c Clear Load Result Data.
d Click Open.
e Click Intact Protein Layout in the 

toolbar.

• The TIC is automatically displayed in 
the Sample Chromatogram Results 
window.

• The Intact Protein layout shows the 
Deconvolution Results window.

2 Open the method to use as a starting 
point for the new method.

a Click Method > Open.
b Select 

BioConfirmIntactProtein-Default.m
c Click Open.

3 Open the Deconvolute (Protein) 
Method Editor section.

• Select Deconvolute (Protein) from the 
Intact Protein section of the Method 
Editor.

If the Method Editor window is not visible, 
click View > Method Editor to display it.
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4 Select the deconvolution algorithm. 
• Use Maximum Entropy.
• Use the automated mass range 

detection.
• Use the limited m/z range of 2400 - 

4000.
• Use 3 for the baseline factor.

a On the Deconvolution tab of the 
Deconvolute (Protein) section of the 
Method Editor, select Maximum 
Entropy as the Deconvolution 
algorithm.

b Mark the Automatic mass range 
detection check box.

c Mark the Use limited m/z range check 
box.

d Enter 2400 - 4000 for the m/z range.
e Enter 3 for the Baseline factor.
f Select Unspecified for the Isotope 

width.

• For more information on these 
parameters, press F1 to open the 
online Help.

5 Use the default settings for Maximum 
Entropy deconvolution.

• Click the Maximum Entropy tab to 
review settings.

6 Run the Find by Protein Deconvolution 
algorithm.

• Click Find and Identify > Find by 
Deconvolution > Proteins.

or 
• Click Find by Protein Deconvolution in 

the toolbar in the Method Editor 
window.

Steps Detailed Instructions Comments
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7 Review deconvolution results. • The results appear in the 
Deconvolution Results window.

8 Open the NIST mAb 2.d data file. a Click File > Open Data File.
b Locate the NIST mAb 2.d sample file.
c Click Open.

• The TIC is automatically displayed in 
the Sample Chromatogram Results 
window.

9 Run the Find by Protein Deconvolution 
algorithm on NIST mAb 2.d.

• Click Find and Identify > Find by 
Deconvolution > Proteins.

10 Review deconvolution results. • The results appear in the 
Deconvolution Results window. 

11 Select both data files in the Sample 
Table window.

a Select one of the sample files in the 
Sample Table window.

b Press the Ctrl button and click the 
other sample file.

• The results for the sample files 
selected in the Sample Table are 
shown in the Deconvolution window 
and other windows.

12 Use Mirror Plot to compare two 
deconvoluted spectra.

a Click the  button to show the 
spectra in list mode.

b Select a spectra from the 
Deconvolution window.

c Press the Ctrl button and select 
another spectra from the other data 
file.

d Click the  button to display the 
spectra in the Deconvolution Mirror 
Plot Results window. 

• Other mirror plots are available:
• MS Spectrum Mirror Plot
• Fragment Spectrum Mirror Plot
• Biomolecule Chromatogram Mirror 

Plot
• Sample Chromatogram Mirror Plot

Steps Detailed Instructions Comments
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Exercise 17. View Biomolecule Information

This exercise shows you how to view biomolecule information for deconvoluted 
spectra.

Steps Detailed Instructions Comments

1 Deconvolute NIST mAb 1.d spectrum. • See “Exercise 14. Determine Protein 
Molecular Weight” on page 75.

• You do not need to repeat the 
deconvolution steps, if you have 
already done them in Exercise 1.

2 View the biomolecule list. • If needed, click View > Biomolecules • See Figure 8 on page 86.

3 Select the biomolecule with mass 
around 148039.3.

• Click the row which has a mass around 
148039.3 in the Biomolecules window.

• The Biomolecule MS Spectrum 
window and the Deconvolution Results 
window are both updated.

• A biomolecule spectrum that displays 
all the charge states from the original 
m/z data for that specific protein mass 
is shown in the Biomolecule MS 
Spectrum Results window.

4 Select the biomolecule selected in 
step 3 in the Biomolecule MS 
Spectrum Results window.

• Click the graphics area for the 
spectrum selected in step 3. 

• You can right-click the title of the 
window and click Floating. Then, you 
can make the window wider.

5 View the charge states found for the 
protein.

a Click  on the Biomolecule MS 
Spectrum toolbar to show the peak 
information.

b Right-click the table and click 
Add/Remove Columns.

c Select the columns in the Available 
Columns list which you want to see.

d Click either Add or Add All ->>

• The following information is displayed 
for the ion set spectrum:
• m/z
• Abundance
• Charge state

See Figure 9 on page 86.
• If you cannot see the graphics when 

the table is displayed, move the cursor 
to between the graphics and the table 
until it looks like . Then, click and 
drag to the right to increase the size of 
the graphics.

6 Switch from List mode to Overlay 
mode in the Biomolecule MS 
Spectrum Results window.

• Click  on the toolbar in the 
Biomolecule MS Spectrum Results 
window.

• See Figure 10 on page 87.

7 Select Biomolecule 1 in the 
biomolecule list. 

• Click the first line of the Biomolecules 
table.

• Notice that the spectrum in the 
Biomolecule MS Spectrum window is 
updated.

8 Select Biomolecule 2 in the 
Biomolecules window. 

• Click the second line of the 
Biomolecules table.
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9 Print a biomolecule report. a Display the Reports section in the 
Method Editor by selecting Method 
Automation > Reports.

b Review the parameters in both the 
Templates and Layout tabs.

c Click Biomolecule Report from the 
File > Print menu to print the report.

• When you print a Biomolecule Report, it 
uses the Intact Protein, the Protein 
Digest, the Released Glycans, the 
Oligonucleotides - Target Plus 
Impurities, or the Oligonucleotides - 
Sequence Confirmation template, 
depending on the workflow used to 
create the results. 

• If the workflow is Custom, then if you 
use the Find Peptides command, the 
Peptide Digest report template is 
used; otherwise, the Intact Protein 
report template is used.

Steps Detailed Instructions Comments

Figure 8. Biomolecules window for NIST mAb 1.d

Figure 9. Peak information for NIST mAb 1.d displayed in the Biomolecule MS Spectrum window
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Figure 10. Biomolecule MS Spectrum Results window for NIST mAb 1.d (Overlay Mode)
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Exercise 18. Open results using versions

This section shows how to select which results to open when you open a data 
file. You can only select which results to load in Networked Workstation mode. In 
Workstation mode, the File version is not available.

If you do not have permission to select results, then this option is grayed out.

Steps Detailed Instructions Comments

1 Select the NIST mAb 1.d data file. a Click File > Open Data File.
b Select the NIST mAb 1.d folder.

• In the previous exercises, results were 
stored with NIST mAb 1.d multiple 
times.

2 Select the File version to open. a Mark Load result data.
b Select the File version to open.
c Click Open.

• You select the file version based on the 
date and time that the version was 
saved.

• You can look at the Results Audit Trail 
window to look at the Reason column 
or the Review Comment column to 
help determine which File version to 
open.

You need to mark the Load 
result data check box before 
you can select which results to 
load. If the list of results is 
grayed out, verify that the 
check box is marked.
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