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Where to find more information

• Online Help provides in-depth information and can be displayed in the 
following ways:

• Click Help from the File menu.

• Press the F1 key to get more information about a window or dialog box.



What is Agilent MassHunter DAR Calculator Software?

What’s New in B.01.01
What is Agilent MassHunter DAR Calculator Software?

Agilent MassHunter DAR Calculator software is a stand-alone program 
specifically designed to investigate drug-to-antibody ratios (DAR) of 
deconvoluted LC/MS sample data acquired from antibody-drug conjugates 
(ADC). The DAR Calculator allows you to interactively view the deconvoluted 
ADC spectrum, interactively and numerically input mass values for the 
unconjugated antibody and the drug/linker (the drug molecule and linker 
complex), adjust peak calculation parameters, and generate DAR calculation 
results. DAR Calculator reports may be saved as PDF and DOCX files, and 
your DAR Calculator investigation can be saved as a DAR file and in a .D 
MassHunter data file.

DAR Calculator provides you with the drug-to-antibody ratios for your sample 
through a sequential set of operations: for intact ADCs and for reduced ADCs.

Automated DAR Calculator Workflow

You can automatically calculate DAR when you create a method with a custom 
workflow in the Agilent MassHunter BioConfirm program. You can then run 
this BioConfirm method from either the Agilent MassHunter Workstation Data 
Acquisition program or from the Agilent MassHunter Walkup software. See 
“Automated DAR Calculator Workflow” on page 17 and “To create and run a 
Data Acquisition worklist” on page 29.

What’s New in B.01.01

• DAR Calculations can be run from the BioConfirm program.

• DAR specific columns in MassHunter Data Acquisition and MassHunter 
Walkup allow for automated DAR calculations. 
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Agilent MassHunter DAR Calculator Software Installation

To install the software
Agilent MassHunter DAR Calculator Software Installation

To install the software

BioConfirm B.08.00 or later must be installed before you install DAR 
Calculator software.

If the G4994AA Agilent MassHunter DAR Calculator Software is not already 
installed on your system, install it as follows.

1 Insert the disk labeled Agilent Technologies ADC DAR Calculator 
Software into the disk drive.

2 From the installation disk, right-click Setup.exe, and then select Run as 
administrator.

3 Follow the instructions on the screen to install the software.

For Excel based reporting to work properly in the BioConfirm program, 
after installing Excel 2013 or Excel 2016, you need to open Excel and click 
Accept on the “First things first” message.

To remove the software

Use Programs and Features in Windows Control Panel to remove Agilent 
MassHunter DAR Calculator Software.
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User Interface

Main Functional Areas
User Interface

Main Functional Areas

The main BioConfirm window consists of three parts: (1) the Menu Bar, (2) the 
Ribbon, and (3) the Main Window. The main functional areas are shown in 
Figure 1.

1. File Menu

The File Menu (Figure 2 on page 5) is shown when you click on the File tab in 
the Ribbon. You can open the Properties dialog box, open the Help file, find 
version information, and lock the program from the File menu.

Figure 1 The main functional areas of DAR Calculator
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User Interface

Main Functional Areas
2. Ribbon

The Ribbon has two parts: the File Menu, and the Home tab. The Home tab has 
six groups.

Figure 2 File Menu

Toolbar Icon Action

• Open an Intact CSV file, one or two Reduced 
CSV files, or a data file

• Close one or all open files
• Save, Save As, or Save All results

• Opens the Edit DAR Method dialog box
• Applies the method that you select to the 

current file
• Saves or Save as the method
• Open a different method to edit

• Lys-Linked (All) can have any number of 
drug molecules attached to the antibody.

• Cyc-Linked (Even) only has even numbered 
DAR peaks available.

• Shows the DAR peaks that are contributing 
to the DAR calculation.
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User Interface

Main Functional Areas
3. Main window

The main window, see Figure 1 on page 4, is further divided into three panes: 
File Browser pane, DAR Deconvoluted Spectrum pane, and DAR Peak List 
pane. The File Browser pane and the DAR Deconvoluted Spectrum pane are 
always visible.

File Browser pane This pane contains a list of the files that are open. It shows 
the file names and the DAR value, if it has been calculated. When you click a 
different file in the list, the information in the DAR Deconvoluted Spectrum 
pane and the DAR Peak List pane are updated. 

You cannot close this pane.

DAR Deconvoluted Spectrum You display deconvoluted spectra in this 
window. In order to determine the DAR value, you enter the DAR 0 value and 
the Drug/Linker value in the toolbar for this pane. The DAR peaks that are 
included in the calculation of DAR are highlighted with vertical gray bars. You 
can remove DAR peaks from the calculation using the Ribbon, the DAR Peak 
List pane, or the shortcut menu.

• Creates a report and saves it as either a PDF 
or a Word document.

• Toggles whether or not the DAR Peak List 
pane is visible

Figure 3 File Browser pane
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User Interface

Main Functional Areas
DAR Peak List pane This pane has two parts: a toolbar and a table. The table 
shows information about each DAR peak in the deconvoluted spectrum. If you 
delete a peak from the DAR Deconvoluted Spectrum, it is also removed from 
this table. You can clear the check box at the beginning of a row in the table to 
remove that peak from the calculation of DAR. By the shortcut menu, you can 
export the table, filter selected peaks, delete peaks, and edit the method.

Figure 4 DAR Deconvoluted Spectrum pane

Figure 5 DAR Peak List pane and shortcut menu
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User Interface

DAR Dialog Boxes
DAR Dialog Boxes

The following dialog boxes are some of the dialog boxes available in Agilent 
MassHunter DAR Calculator Software. See online Help for more information.

Edit DAR Properties Dialog Box

This dialog box allows you to set global parameters that are used when you 
open a new CSV file. 

To open this dialog box Click Properties in the File menu.

Edit DAR Method Dialog Box

You can edit a method and save the settings that you want to apply to the 
deconvoluted spectrum. If you are processing similar data files, then you can 
apply a method instead of manually entering information when you open a 
different file.

Figure 6 Edit DAR Properties dialog box
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User Interface

DAR Dialog Boxes
To open this dialog box Click  in the Method group in the Ribbon. You can 
instead click Edit Method in the File Browser shortcut menu.

Select method to apply Dialog Box

You can select any method that was saved, and this method is applied to the 
current file.

To open this dialog box Click  in the Method group in the Ribbon.

Figure 7 Edit DAR Method dialog box

Figure 8 Select method to apply Dialog Box
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Basic Tasks

To start the DAR Calculator program
Basic Tasks

Basic DAR Workflow

“To start the DAR Calculator program” on page 10

“To create CSV files in BioConfirm” on page 10

“To process Intact CSV file” on page 12

“To process Reduced CSV files” on page 13

“To edit results” on page 14

“To create a report” on page 15

To start the DAR Calculator program

To start the DAR Calculator program, do one of the following:

• Click the DAR Calculator icon ( ) on the desktop.

• Click Start > All Programs > Agilent > MassHunter Workstation > DAR 
Calculator.

To create CSV files in BioConfirm

The first step in using the MassHunter DAR Calculator software is to create 
CSV files in the MassHunter BioConfirm software containing the deconvoluted 
mass peaks.
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Basic Tasks

To create CSV files in BioConfirm
1 Open your LC/MS sample data file.

2 Edit the Deconvolute (MS): Protein method parameters.

3 Run Deconvolute (Protein) from the Method Editor.

4 Review the deconvolution results plot and adjust the method parameters.

5 Export the deconvolution results as a text file (CSV file) from the 
deconvolution plot.

See the online Help for detailed information about each step.

Figure 9 Creating a CSV file
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Basic Tasks

To process Intact CSV file
To process Intact CSV file

You follow these general steps to process an intact CSV file.

1 Open a deconvoluted ADC spectrum (CSV file).

2 Select the ADC Type as Lys-Linked (All). (any number of drug molecules 
per antibody) or Cyc-Linked (even) (only even numbers of drug molecules 
per antibody).

3 Enter the mass for the unconjugated antibody (DAR 0) in the toolbar.

4 Enter the mass for the drug/linker (the drug molecule and linker complex).

5 Review the results and adjust the method, peak properties, and plot.

6 Create a DAR report (PDF or DOCX file).

7 Save your investigation (DAR file).

See the online Help for detailed information about each step.

Figure 10 Process an Intact CSV file
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Basic Tasks

To process Reduced CSV files
To process Reduced CSV files

Follow these general steps to process reduced CSV files.

See the online Help for detailed information about each step.

1 Open the deconvoluted ADC spectra for the light and heavy chain 
immunoglobulins (CSV files).

2 Enter the mass for the unconjugated antibody (DAR 0) for the heavy chain.

3 Enter the mass for the unconjugated antibody (DAR 0) for the light chain.

4 Enter the mass for the drug/linker (the drug molecule and linker complex).

5 Review the results and adjust the method, peak properties, and plot.

6 Create a DAR report (PDF or DOCX file).

7 Save your investigation (DAR file).

Figure 11 Process reduced CSV files
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Basic Tasks

To edit results
To edit results

To remove a peak

• Clear the peak icon in the toolbar.

• Clear the check box in the DAR Peak List pane.

To delete a peak

• Select the peak in the DAR Peak List table and press Delete on the keyboard.

• Select the peak in the DAR Peak List table. Right-click the peak and click 
Delete Peak > Delete Peak.

• Select the peak in the DAR Deconvoluted Spectrum pane. Right-click the 
peak, and click Delete Peak > Delete Peak.

To add a peak manually

1 Open one or two CSV files.

2 Process the data. See “To process Intact CSV file” on page 12 and “To 
process Reduced CSV files” on page 13.

3 If you have two reduced CSV files open, click either the Heavy Chain plot of 
the Light Chain plot. The peak will be added to only one peak list.

4 Click  on the DAR Deconvoluted Spectrum toolbar.

5 Click the location for the first limit.

6 Click the location for the second limit.

To change integration results

1 Open one or two CSV files.

2 Process the data. See “To process Intact CSV file” on page 12 and “To 
process Reduced CSV files” on page 13.

3 Zoom in around the peak that you want to modify in the DAR Deconvoluted 
Spectrum pane.

4 In the DAR Peak List table, click a value in the Start Mass (DA) column or in 
the End Mass (Da) column. The value in the cell is selected.

5 Click the location in the spectrum that you want to use as the Start Mass or 
the End Mass for the peak. When you click a different location, the software 
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Basic Tasks

To create a report
automatically changes either the Start Mass or the End Mass for that peak 
and recalculates the Area and % Area (or Height and % Height).

To modify properties for the current file

1 Open one or two CSV files.

2 Process the data. See “To process Intact CSV file” on page 12 and “To 
process Reduced CSV files” on page 13.

3 Open the Edit DAR Method dialog box. Do one of the following:

• Right-click the DAR Deconvoluted Spectrum pane and click Edit 
Method.

• Right-click the DAR Peak List pane and click Edit Method.

• Right-click the file name in the File Browser pane and click Edit Method.

4 Review the parameters and make any changes. You can change how Peak 
area is reported. You can also change how the Peak baseline is determined. 
You can also change the Maximum DAR peak number.

5 Click Apply. The changes are made to the current file only.

To create a report

1 Click  or  under  in the toolbar. The Save As dialog box opens.

2 Enter a File name. You can also switch to a different folder.

3 Click Save. The report is opened automatically.

To export results

Export DAR Peak List table

You can only export a DAR Peak List table if the DAR Peak List contains one or 
more peaks.

1 Select the table which you want to export.

2 Right-click the table in the DAR Peak List pane, and click Export Table > 
CSV or Export Table to > XLS.
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Basic Tasks

To export results
3 Enter the File name. You can also change to a different folder.

4 Click Save.

Export DAR spectrum

You can export a DAR spectrum to one of these formats: BMP, JPEG, PNG, or 
TIFF.

1 Select the spectrum that you want to export.

2 Right-click the spectrum in the DAR Deconvoluted Spectrum pane, and 
click one of the following

• Export Plot to > BMP

• Export Plot to > JPEG

• Export Plot to > PNG

• Export Plot to > TIFF

3 Enter the File name. You can also change to a different folder.

4 Click Save.
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Automated DAR Calculator Workflow

To export results
Automated DAR Calculator Workflow

The topics in this section will help you get started using the Agilent 
MassHunter DAR Calculator Software with Agilent MassHunter BioConfirm 
software and Agilent MassHunter Acquisition for TOF/QTOF with Agilent 
MassHunter Walkup software.

1 Create a DAR Calculator method and save it.

2 Create a method with a Custom workflow in BioConfirm.

a Select Custom as the workflow in the BioConfirm program.

b Select Intact Protein Deconvolution with DAR Calculations as an action 
in the BioConfirm method.

c Save the BioConfirm method to the same file as the DAR method.

3 Create an acquisition method in the Agilent MassHunter Data Acquisition 
program. Link or copy the combined BioConfirm and DAR method just 
created.

4 Create a Walkup Method that links to the Acquisition Method that you just 
created.

5 Create a Walkup Workflow to configure custom columns.

For more information, see the following topics:

• “To create a DAR Calculator method” on page 18

• “To create a custom BioConfirm method” on page 19

• “To create a Data Acquisition method” on page 22

• “To create a Walkup Method” on page 23

• “To create a Walkup Workflow” on page 25
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Automated DAR Calculator Workflow

To create a DAR Calculator method
To create a DAR Calculator method

The Intact DAR 0 mass and Drug/linker mass which you enter in the method 
are the default values that are used during automation. When you are 
automatically doing DAR calculations, you enter the appropriate values for 
your sample.

1 Click  in the Method group in the Ribbon.

2 Click the Parameters tab.

3 Click either Lysine-Linked or Cystine-Linked.

4 Enter the Intact DAR 0 mass. This mass is used as the default Intact DAR 0 
mass.

5 Enter the Drug/linker mass. This mass is used as the default Drug/linker 
mass.

6 Mark the selected peaks. These peaks are included in the calculation of 
DAR.

7 Click the Properties tab. Review the Integration Properties and the Max 
DAR Peak Number.

8 Click the Report tab. Review the parameters.

Figure 12 Edit DAR Method dialog box
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Automated DAR Calculator Workflow

To create a custom BioConfirm method
9 Save the method. Click  in the Method group in the ribbon and select 
either Save or Save as.

To create a custom BioConfirm method

Use this procedure to create a BioConfirm method which also does DAR 
calculations. If you enter a Sequence, then the Match Sequences algorithm is 
also run.

1 Start the BioConfirm program. Click on the desktop or click Start > All 
Programs > Agilent > MassHunter Workstation > BioConfirm B.08.00. 
You need to use version B.08.00 or later of the BioConfirm program.

2 Open the default.m method. Click Method > Open. Select the default.m 
method in the BioConfirm\B.08.00 folder.

3 If the Method Editor window is not visible, click View > Method Editor.

4 Click the Method Automation > Workflow and Sequences section in the 
left pane.

5 Select Custom for the Workflow.

6 Select either reduced or non-reduced for the Condition.

7 (optional) Click the  button next to the Sequence/Masses parameter to 
select a sequence. See the online Help for BioConfirm for more information 
on adding a sequence using the Sequence Manager.

If you do not enter a sequence, then the Match Sequences algorithm is not 
run. 

For the example data file (Sample_Reduced.d), here are the sequences:

Light Chain:

DIQMTQSPSSLSASVGDRVTITCRASQDVNTAVAWYQQKPGKAPKLLIYSASF
LYSGVPSRFSGSRSGTDFTLTISSLQPEDFATYYCQQHYTTPPTFGQGTKVEIK
RTVAAPSVFIFPPSDEQLKSGTASVVCLLNNFYPREAKVQWKVDNALQSGNS
QESVTEQDSKDSTYSLSSTLTLSKADYEKHKVYACEVTHQGLSSPVTKSFNRG
EC

Heavy Chain:

EVQLVESGGG LVQPGGSLRL SCAASGFNIK DTYIHWVRQA PGKGLEWVAR 
IYPTNGYTRY ADSVKGRFTI SADTSKNTAY LQMNSLRAED TAVYYCSRWG 
GDGFYAMDYW GQGTLVTVSS ASTKGPSVFP LAPSSKSTSG GTAALGCLVK 
DYFPEPVTVS WNSGALTSGV HTFPAVLQSS GLYSLSSVVT VPSSSLGTQT 
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Automated DAR Calculator Workflow

To create a custom BioConfirm method
YICNVNHKPS NTKVDKKVEP KSCDKTHTC PPCPAPELLG GPSVFLFPPK 
PKDTLMISRT PEVTCVVVDV SHEDPEVKFN WYVDGVEVHN AKTKPREEQY 
NSTYRVVSVL TVLHQDWLNG KEYKCKVSNK ALPAPIEKTI SKAKGQPREP 
QVYTLPPSRE EMTKNQVSLT CLVKGFYPSD IAVEWESNGQ PENNYKTTPP 
VLDSDGSFFL YSKLTVDKSR WQQGNVFSCS VMHEALHNHY TQKSLSLSPG

8 (optional) Click the  button next to the Mods and Profiles parameter to 
select modifications and profiles.

9 (optional) Mark the check box next to the Enzymes that you used.

10 In the Available actions list, select Intact Protein Deconvolution with 
DAR Calculation.

This one action does the following

• Runs the Intact Protein Deconvolution algorithm.

• Runs the Match Sequences algorithm (if a sequence is provided).

• Runs the DAR Calculations algorithm.

• Generates a report.

11 Click the  to move this action to the Actions to be run list.

Figure 13 Method Editor window in the MassHunter BioConfirm program
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Automated DAR Calculator Workflow

To create a custom BioConfirm method
12 Review the parameters in the Intact Protein section. 

• Extract Chromatogram (MS)

• Extract Spectrum (MS)

• Deconvolute (Protein)

• Match Tolerances

13 Save the BioConfirm method to the same method name as the DAR method. 
BioConfirm does not overwrite the DAR method. Instead, BioConfirm 
method parameters are added to the DAR method producing a combined 
BioConfirm and DAR method.
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Automated DAR Calculator Workflow

To create a Data Acquisition method
To create a Data Acquisition method

Use this procedure to create a Data Acquisition method that links to the 
BioConfirm method.

1 Open the Agilent MassHunter Workstation Data Acquisition program. You 
can either double-click the Data Acquisition icon on the desktop or in the 
Agilent MassHunter Workstation group folder. You can also click Start > All 
Programs > Agilent > MassHunter Workstation > Data Acquisition.

2 Enter values for all of the LC modules configured for the instrument.

3 Enter the MS parameters in the TOF or Q-TOF tab. See the Data Acquisition 
Quick Start Guide for more information.

4 Click the DA tab.

5 Click the BioConfirm tab.

6 Mark the BioConfirm Automation check box.

7 Click the Copy or Link button.

8 Select the BioConfirm method that you created which also contains the 
DAR method. See “To create a custom BioConfirm method” on page 19. 

9 Save the Data Acquisition method. You click either Method > Save or 
Method >Save As.

Figure 14 DA > BioConfirm tab in the Method Editor window in Data Acquisition
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Automated DAR Calculator Workflow

To create a Walkup Method
To create a Walkup Method

Use this procedure to create a Walkup method that uses the Data Acquisition 
method that you created. You must be a system administrator to create a 
Walkup Method.

See “To create a Data Acquisition method” on page 22.

1 Start the MassHunter Walkup program. From the Data Acquisition 
program, click Walkup > Start Software. You need to enter a valid name 
and password.

2 In the Walkup software, click Administration ( ) in the Ribbon. You need 
to log in as an administrator.

3 Click Configuration in the left pane.

4 Click Walkup Methods ( )in the Configuration section in the left pane.

5 Click <Add New Walkup Method> in the right pane.

6 Enter information in the <Add New Walkup Method> section. Enter the 
Walkup Method Name and the Estimated Runtime.

7 In the Data System Method Details section, click  to select the folder 
where the method is saved. Click OK.

8 Select the Data Acquisition method you updated in “To create a Data 
Acquisition method” on page 22.

9 Enter the Injection Volume Minimum, Nominal, and Maximum.
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Automated DAR Calculator Workflow

To create a Walkup Method
10 Click Save. 

11 Click Verify in the Verify & Save group in the Ribbon.

12 Fix any errors.

13 Click Save in the Verify & Save group in the Ribbon.

Figure 15 Walkup Methods section in the Walkup Administration program
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Automated DAR Calculator Workflow

To create a Walkup Workflow
To create a Walkup Workflow

Use this procedure to create a Walkup Workflow so that a user can submit a 
DAR 0 value and a Drug/Linker value at the time of sample submission.

1 Start the MassHunter Walkup program. From the Data Acquisition 
program, click Walkup > Start Software. You need to enter a valid name 
and password.

2 In the Walkup software, click Administration ( ) in the Ribbon. You need 
to log in as an administrator.

3 Click Configuration in the left pane.

4 Click Workflows ( ) in the Configuration section in the left pane.

5 Click <Add New Workflow> in the right pane.

6 Enter a Workflow Name.

7 In the Workflow Columns section, enter DAR 0 Mass for the Column 
Display Name.

8 Select Theoretical DAR 0 Mass as the Column Type.

9 Enter Drug/Linker Mass for the Column Display Name.

10 Select Theoretical Drug/Linker Mass for the Column Type.
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Automated DAR Calculator Workflow

To create a Walkup Workflow
11 Click Save. 

12 Click Verify in the Verify & Save group in the Ribbon.

13 Fix any errors.

14 Click Save in the Verify & Save group in the Ribbon.

Figure 16 Walkup Workflows section in the Walkup Administration program
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Automated DAR Calculator Workflow

To submit a sample in Walkup that calculates DAR
To submit a sample in Walkup that calculates DAR

Use this procedure to submit a sample that will automatically calculate DAR. 
You can enter the DAR 0 Mass and the Drug/Linker Mass if you want to use 
different values than saved in the method.

1 Start the MassHunter Walkup program. From the Data Acquisition 
program, click Walkup > Start Software. You need to enter a valid name 
and password.

2 In the Walkup software, click Submit Samples.

3 Select your User Name and enter the Password.

4 Select the DAR workflow that you created for the Workflow.

5 Enter the Number of Samples.

6 Click Next. The DAR 0 Mass column and the Drug/Linker Mass column are 
automatically displayed in the table because you selected the DAR 
workflow.

7 Enter the Sample Name.

8 Enter the DAR 0 Mass.

Figure 17 User Login page of the Sample Submission dialog box
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Automated DAR Calculator Workflow

To submit a sample in Walkup that calculates DAR
9 Enter the Drug/Linker Mass.

10 Select the Walkup Method that you created.

11 Enter the Injection Volume.

12 Click Next.

13 Place your vial in the position indicated. 

14 Click Finish.

Figure 18 Table on the Sample List page
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Automated DAR Calculator Workflow

To create and run a Data Acquisition worklist
To create and run a Data Acquisition worklist

Use this procedure to create a Data Acquisition worklist that adds columns for 
the DA Workflow, the drug/linker, and the DAR 0 mass (or masses).

1 Open the Agilent MassHunter Workstation Data Acquisition program. You 
can either double-click the Data Acquisition icon on the desktop or in the 
Agilent MassHunter Workstation group folder. You can also click Start > All 
Programs > Agilent > MassHunter Workstation > Data Acquisition.

2 Click the Worklist tab to show the Worklist window. If the Worklist window 
is not visible, click View > Worklist.

3 Right-click the upper left corner of the worklist and click Add Column(s). 
You can also click Worklist > Add Column(s).

4 Select DAR 0 Mass for the Column Type.

5 Enter the Column name. If you want to enter a light DAR 0 and a heavy 
DAR 0, then you still only add one DAR 0 Mass column. The user enters two 
values into this column separated by a comma.

6 Click OK.

7 Click Worklist > Add Column(s). 

8 Select Drug/Linker Mass for the Column Type.

9 Enter the Column name.

10 Click OK.

11 (optional) Add a column for Expected DAR or DAR Range. These values 
will be included in the DAR report. Do not add the DA Workflow column. 

Figure 19 Add Columns dialog box
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Automated DAR Calculator Workflow

To create and run a Data Acquisition worklist
This column is used to override the BioConfirm Workflow specified in the 
method; however, to do DAR calculations, the DA Workflow must be 
Custom.

12 Add one or more samples to the worklist. Select the method created in “To 
create a Data Acquisition method” on page 22. Enter the DAR 0 Mass and 
the Drug/Linker Mass. If you want to enter DAR 0 for a light chain and for 
a heavy chain, enter both values in the DAR 0 Mass column and separate 
them with a comma. For example, you can enter 12000, 94000.

13 Click Worklist > Worklist Run Parameters. The Worklist Run Parameters 
dialog box opens.

14 Select Both Acquisition and DA or DA Only for Part of method to run. You 
select DA Only if you have already acquired the data files.

15 Review the other parameters.

16 Click OK.

17 Save the worklist. Click Worklist > Save or Worklist > Save As.

18 Run the worklist. Click Worklist > Run. You can also click  on the 
main toolbar to run the worklist.

Figure 20 Worklist with DAR columns
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